WordPress.org

Ready to get started?Download WordPress

Forums

visualCaptcha
Visual Captcha is dead when filling out a form (8 posts)

  1. hrrubin
    Member
    Posted 2 years ago #

    I installed the plugin (with no problems) and while it does work on the login screen, it is completely dead when filling out a form. There no difference to whether I'm logged in or not.

    My example: http://vonbuchwald.com/blog/wordpress/herreraften-2/

    http://wordpress.org/extend/plugins/visualcaptcha/

  2. jmigcosta
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hello hrrubin,
    thank you for your feedback.
    Could you please tell me what is your WordPress version?
    Could you please confirm that you have the module enable on the the admin side and that you have the "Comment Form" option checked?
    Do you use any plugin for form processing?
    Does your template build the form using the WordPress standard methods? (I guess this is the problem source).

    Hope to hear from you.

    cheers

  3. jmigcosta
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hello again hrrubin
    do you still need assistance on this subject? :)

    cheers

  4. hrrubin
    Member
    Posted 2 years ago #

    Hello again and sorry for the delay.
    I just reinstalled it again and seeing the same disabled stance.

    Version: 3.5.1
    I don't have any form plugins active, so the forms are wordpress-true code. Comment form is checked under every post under Event.

    What I find interesting is the fact, that it's working on the login page. So clearly I have done something :)

  5. hrrubin
    Member
    Posted 2 years ago #

    A note: The sound captcha is working though. But you can't rely on that of course.

  6. jmigcosta
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hello again hrrubin,
    The page is loading to different versions of jquery:
    1 - at line 32:
    <script type='text/javascript' src='http://vonbuchwald.com/blog/wordpress/wp-includes/js/jquery/jquery.js?ver=1.8.3'></script>

    2 - at line at line 63
    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.js"></script>

    I guess the line 63 is from your theme :) jQuery should be included according the wordpress methods :)
    Please take a look at the following link, you will find there the correct way to include jQuery on your theme.
    http://digwp.com/2009/06/including-jquery-in-wordpress-the-right-way/

    hrrubin I hope this helps you correcting the problem.
    Thank you for using visualCaptcha and if you need further assistance please feel free contact us again :)

    Cheers

  7. hrrubin
    Member
    Posted 2 years ago #

    How do I make sure that the wp-include jquery doesn't load? I tried deleting it, but somewhere it says it should load.

  8. jmigcosta
    Member
    Plugin Contributor

    Posted 2 years ago #

    hi hrrubin,
    to include jquery you should use <?php wp_enqueue_script("jquery"); ?>.
    Please take a look at the wp_enqueue_script() reference:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    "The safe and recommended method of adding JavaScript to a WordPress generated page is by using wp_enqueue_script(). This function includes the script if it hasn't already been included, and safely handles dependencies."

    This will prevent your wordpress from loading twice the same scripts.

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.