WordPress.org

Support

Support » How-To and Troubleshooting » Visual and HTML Editor are missing

Visual and HTML Editor are missing

  • Hi,

    My visual and HTML Editor toolbars are missing, I’ve looked extensively throughout the support forum to only come across unsolved posts or solutions that don’t work for me. I have gone to the User panel and checked and unchecked the “Disable the visual editor when writing”…I’ve deactivated all my plug-ins with no luck. I’ve viewed the Dashboard on both Firefox and Safari with the same results. I check to make sure my host/server uses php 5 (which is good) and I’ve re-uploaded WP 3.1.3 TWICE! So I’m really quite dumbfounded. Here’s the kicker, I have another site I created using the same theme on the same server and the Visual and HTML editor toolbars are there…what the?

    The theme I’m using is called “inFocus” which I purchased from Theme Forest, it’s had over 5000 downloads and is the number one theme on Theme Forest. I asked the developer and he said it’s a WordPress issue.

    Please there has to be an answer to this issue by now since this problem has been around for several years now, at least from the dates on this forum. I would appreciate any help on this.

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Hi

    Same here, I have just upgraded a website to WP 3.1.3 and my Visual Editor is not working correctly. In the visual pane my icons/buttons are not displaying. Also, my content is displaying as HTML code – fine for me but not fine for my non-techy client using the website.

    Any ideas on how to fix this?
    Cheers!
    Orla

    I had the same problem. I found a fix but it was so specific to my specific setup that I can’t imagine it being the root cause.. but perhaps a symptom?

    I found an error in my console for a missing JS file which traced back to a plugin, “Scissors for 2.9” — I disabled the plugin and tracked down what I can only guess is its replacement: http://wordpress.org/extend/plugins/scissors-continued (great cropping utility, btw). I installed and activated the new plugin and it works great. I noticed some other quirks w/ the new 3.1.3 update, so maybe there’s something deeper conflicting with plugin architectures.

    Best of luck,

    Dustin

    ok, I’ve been dealing with this too and it’s been driving me crazy. some of my wp sites are fine while others are having the same issues. after everything else I ran across an older success story on this issue where they ended up deleting their browser history and closing and reloading their browser. That didn’t work for me, BUT I do use Firefox a lot and so I tried using my explorer and wow… it worked… so maybe try a different browser.

    It seems that there are a lot of people with this issue and large number of ways for this problem to be created. The hard part is trying to find the problem and solution that fits yours. It’s like there is one issue, 50 ways to create that issue and about 40 of them have solutions, each very specific to each problem.

    If this doesn’t work, keep looking! Here are other threads with this issue and the many solutions and ideas for all of these problems that have the same issue:

    http://wordpress.org/support/topic/visual-editor-disappearing-1?replies=12

    http://wordpress.org/support/topic/visual-editor-lost-after-upgrade-to-30?replies=18

    http://wordpress.org/support/topic/visual-editor-notes-solution-for-fixing?replies=1

    Thank you so much!!! Because of this thread I deactivated one of the widgets that i wasn’t even using, and my view tab is back to normal, and I’m once again able to add pictures normally, as well as add Post Tags again.

    Same problem here, only it’s for a new site and I haven’t even installed any plugins yet. And I’m using the same theme (Woo Theme’s VibrantCMS) on a different site with no problems. Problem exists in both Safari 5.0.5 and Firefox 4.0.1.

    I had this problem recently after an upgrade to WP 3.2.

    To fix it, first I re-installed WP but to no effect. Then I checked to see if the theme was the problem (it wasn’t), updated the theme framework (no change), checked to see if NextGen Image Gallery was the problem (nope), and deleted all deactivated plugins. I got some error messages indicating that some of the deactivated plugins really don’t exist anymore. After this the visual editor came back. I’d guess that the plugin records were out of whack and something in the 3.2 upgrade choked on that.

    I also had this problem right after I installed 3.2.1. After a lot of searching )including previous topics here which are now closed), I finally found out that the issue was because I was using CloudFlare’s Auto Minify feature. Disable the JS auto minify and all is back up and running. Just telling you this in case anyone of you are using CloudFlare. If you are, try that one first…

    Hope this helps.

    @ditesco Thanks so much for that. I use the Cloudflare service and unchecking the JS autominify function then purging the cache has brought back my visual editor 🙂 I’m on wordpress 3.2.1

    @totalgaz.. welcome. Glad I could help

    Hello. I’ve installed wordpress 3.2.1. I am learning this platform and I also can’t see the ‘visual’ part of my html editor as well. I am using firefox 5.0.1. I haven’t installed any plugins or anything yet. Can anyone tell me what I need to do to resolve this problem? Should I contact my host perhaps?

    Never mind, I sifted thru all of these posts and found what was wrong. Thanks.

    pl2prosperity

    @pl2prosperity

    @ditesco…Thank you so much for your advise; I finally solved the puzzle. Like everybody else, I too tried everything that I could get my hands on all over the internet for the last 7 days, but, it was the Cloudflare Auto Minify solution that clicked for me. Yes, indeed, everyone using cloudflare should give that the first shot.

    ditesco

    @ditesco

    @pl2proseperity That0s great. Glad it helped…

    greggh3

    @greggh3

    I’m not sure if this applies to any of you, but a client had the same problem, but it was related to their user settings. If you go to your profile, the top checkbox is to disable the visual/html editor.

    It could be this for some of you.

    jonasll

    @jonasll

    Quick note: make sure you go to your profile, and see if the top checkbox is ticked ( disable the visual/html editor)

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Visual and HTML Editor are missing’ is closed to new replies.