• Resolved svoberman

    (@svoberman)


    Even after updating to 1.0.37 it still has the visitors bug (cleared browser and site cache, updated to 1.0.37, etc. all done).

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Lap

    (@lapzor)

    Please share a link to where I can see this on your website. Thank you!

    I also tried a different browser where I never logged in.
    Zero visitors since December 7.

    Plugin Support Lap

    (@lapzor)

    When using any caching plugin that minifies javascript, please exclude /wp-content/plugins/koko-analytics/assets/dist/js/script.js from the minification process. The Koko script is already highly optimized and minified and can’t be minified any further, in fact trying to do so may break it as is the case here.

    Hope that helps. If you have any questions, please let me know!

    mstoetzel

    (@martinstoetzel)

    Problem pesists after update

    • Plugin updated to 1.0.37 ✅
    • Disabled JS Minification in WP-Rocket Caching : /wp-content/plugins/koko-analytics/assets/dist/js/script.js ✅
    • Still visitors and pageviews are only 10% compared to before 1.0.36 update 😢

    Website: https://www.madamecuisine.de

    • This reply was modified 1 year, 5 months ago by mstoetzel.
    • This reply was modified 1 year, 5 months ago by mstoetzel.
    • This reply was modified 1 year, 5 months ago by mstoetzel.
    • This reply was modified 1 year, 5 months ago by mstoetzel.
    Plugin Support Lap

    (@lapzor)

    I just checked your site, and for me Koko is executing properly.
    It’s possible that the Koko cron-job isn’t executing.

    You can install a plugin like Advanced Cron Job Manager to see if anything is stuck on the top of the queue, and if the Koko task is scheduled.

    Saving the Koko settings should re-create the cron job if it’s not there anymore.

    mstoetzel

    (@martinstoetzel)

    After switching off and on all JS Minification settings in WP Rocket, I finally found a solution and stats are recorded again. Phew… 😊

    Hi @martinstoetzel what was your solution getting koko run with WP Rocket? I have the same problem right now, that it works for logged in users (without caching), but not with anonymous visitors in private browser windows. Thanks!

    Plugin Support Lap

    (@lapzor)

    When using any caching plugin that minifies javascript, please exclude /wp-content/plugins/koko-analytics/assets/dist/js/script.js from the minification process. The Koko script is already highly optimized and minified and can’t be minified any further, in fact trying to do so may break it as is the case here.

    If your caching plugin doesn’t have the option to exclude scripts from minification, try with minification or javascript optimizations turned off.

    Hope that helps. If you have any questions, please let me know!

    @lapzor Yes, I have done that. But I think I still have a problem with WP Rocket. I have some page views in my statistics. But if I request a page within a private browser or an other browser where I am not logged in, I don’t see it there.

    Perhaps you want to have a look on it: https://www.meinstutensee.de/2023/01/kinderfest-beim-reitverein/

    Plugin Support Lap

    (@lapzor)

    your koko tracker is working properly as far as I can see.
    note that it collects data every 5 minutes or so, so you won’t see your test visit immediately.

    Ah, thanks! I missed the 5 minutes. I will check it again.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Visitors are not showing’ is closed to new replies.