Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » Visibility settings do not work

  • Resolved tinshapes

    (@tinshapes)


    Hello,

    I am trying to setup the visibility settings for a pop-up so that we can disable the pop-up to EU countries however the settings do not work. Here is what I have tried so far:

    • Setting the visibility to only show when any condition matches “only these countries” and I have set 2 countries
    • Setting the visibility to hide when any condition matches “any country except” and my 2 countries
    • I have tried to run a test where I ALL condition parameter instead of the ANY
    • I have tried using the HIDE parameter instead of SHOW
    • I have reset the plugin and re-created the pop-up trying the above combinations
    • I have ensured that my integrations are working
    • I have ensured that with each change WPRocket Cache has cleared the site cache and OpCache
    • I have ensured that each test was performed with a clean browser window (no cached visits)

    I am at a loss as to how to resolve this. Can you recommend any other changes/settings to try?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tinshapes

    I hope you are doing well!

    I apologize for the inconvenience this issue has caused. I could replicate the same with the “Visitor’s Country” condition, not working on my end, and I’m afraid this is a bug. I’ve reported it to our developers so they could fix it.

    If there will be a quick fix available, before the next plugin version will be released, we will share it in this thread.

    Kind regards,
    Nastia

    Thread Starter tinshapes

    (@tinshapes)

    Hi Nastia,
    Thank you so much for your response, I’ll stand by for the update.

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tinshapes

    I trust you are doing well

    Would you please check on your end if you still having this issue?

    Looking forward to your reply!

    Cheers,
    Nastia

    Thread Starter tinshapes

    (@tinshapes)

    Hi Natasia,

    I have updated to the latest version and the issue is still there. I have tried the same visibility settings/combinations as above and the pop-up will still appear in the countries I have specified they not appear.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @tinshapes,

    Could you please go to Hustle > Pop-ups, click on the gear icon next to your popup and export it from there.
    Upload the export file to any file sharing service like GDrive or Dropbox and share the download link here so we can check your settings and do some additional tests on our end.

    Cheers,
    Predrag

    Thread Starter tinshapes

    (@tinshapes)

    Hi Pedrag,

    Is there a more private way to share a link with you?

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tinshapes

    I hope you are doing well!

    I apologize for the late reply! Please email the export file to us directly to contact@wpmudev.org.

    Please add as a subject “ATTN:Nastia” so an email would not be lost. And include in the content of the email a link back to this thread.

    Looking forward to your reply!

    Kind regards,
    Nastia

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tinshapes

    I trust you’re doing well!

    Thank you for sending a file Export. I see that you’ve added “Visitor’s Country” as a Condition. I could replicate the same issue, that a pop0up was still showing up even though the conditions set not supposed to allow it.

    Our developers have been informed about this issue and it should be fixed in teh future plugin version.

    Have a good day and take care!

    Cheers,
    Nastia

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tinshapes

    I trust you are doing well!

    After further testing I see that the issue came from a caching plugin. are there any caching enabled on your end? If yes, please temporarily deactivate the caching plugin and check if the Visibility options will work on your end.

    Please advise,

    Kind regards,
    Nastia

    Thread Starter tinshapes

    (@tinshapes)

    Hi Nastia,

    Thank you so much for your help, I really appreciate that!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Visibility settings do not work’ is closed to new replies.