Support » Plugin: Airpress » Virtual post Only work when logged in

  • I set up a page to show every record from a table.
    The page works when I am logged in as admin, but if we look at the page as a normal user it show no results. Empty page as you can see in the linked page.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter sgervais71

    (@sgervais71)

    Extra info: Its is a 404 error page with this error message:

    Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 2 in /home/abonneme/public_html/sgf/wp-includes/class-wp.php on line 223

    Warning: Cannot modify header information – headers already sent by (output started at /home/abonneme/public_html/sgf/wp-includes/class-wp.php:223) in /home/abonneme/public_html/sgf/wp-includes/pluggable.php on line 1296

    Thread Starter sgervais71

    (@sgervais71)

    Extra info: landing page
    on this other page, that is also a virtual post but for a single item, the content is displayed, but at the top it gives the same error:

    error: Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 2 in /home/abonneme/public_html/sgf/wp-includes/class-wp.php on line 223

    Plugin Author chetmac

    (@chetmac)

    My guess is that you may have a VirtualPost configured that has a “bad” URL Pattern. The error (line 223) is smack dab in the middle of where WordPress is parsing the request (which relies on rewrites that Airpress and other plugins register).

    If you want to copy/paste the URL Patterns for your various VirtualPosts into this thread, I’ll take a look.

    Thread Starter sgervais71

    (@sgervais71)

    Plugin Author chetmac

    (@chetmac)

    Are you running any caching plugins? If so, have you tried disabling it to see if that helps?

    Thread Starter sgervais71

    (@sgervais71)

    I did try to deactivate all plugins BUT airpress and it still shows the error.
    But since you are helping, I just deactivated the cache plugin again. But still not working.

    Plugin Author chetmac

    (@chetmac)

    Strange. If you want to schedule some time for a screenshare for us to try and dig deeper you can do so at chetmac.com/contact/

    In the meantime, you could try renaming your pages/paths (in case there is a weird conflict somewhere). So instead of

    ^repertoire/?$
    ^landing/([^/]+)/?$

    you could try
    ^newrepertoire/?$
    ^newlanding/([^/]+)/?$

    Thread Starter sgervais71

    (@sgervais71)

    Renaming repertoire to repertoire-pcm fixed one problem with the repertoire page.
    It now shows the table records
    BUT the Warning: preg_match(): error is still on both pages.
    So I guess there was two separate problems.

    Yes It would be very nice to try to work this through with a screen share

    Thread Starter sgervais71

    (@sgervais71)

    New interesting fact. The error is also in the backend.
    It is in every page that is published on the website (airpress related or not)
    To test it, I created new page not related to any virtual post of fields, when airpress is activated there is the same preg_match() error. And when deactivated the error goes away.

    Screenshot:
    Capture d’écran, le 2020-09-17 à 17.20.54<script async src=”//embedr.flickr.com/assets/client-code.js” charset=”utf-8″></script>

    Plugin Author chetmac

    (@chetmac)

    Do you have any special characters or accent marks (like é) in your VirtualPost configurations anywhere?

    Also, what is your permalink setting?
    /wp-admin/options-permalink.php

    Thread Starter sgervais71

    (@sgervais71)

    Fixed the problem completely. After renaming the pages/paths so it it is not the same as the name of a real page, I also needed to update the menus to the new page/path.
    Now there is no more preg_match error.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.