WP Video Lightbox
[resolved] Vimeo Autoplay (5 posts)

  1. dstrosin
    Posted 2 years ago #

    If I want my Vimeo video to autoplay in a pop-up, what is the correct code that I should be using with your plugin?

    The video I am specifically talking about loads when your click on the laptop image of our home page: http://www.smartimage.com but does not autoplay.



  2. gabevanlelyveld
    Posted 2 years ago #

    Cool, I've been working with WP for three days now and I think I might actually be able to help someone.

    I had the same problem. Here's what worked.

    Go to your FTP File Manager with your web host (or wherever it is). Go to wp-content/plugins/wp-video-lightbox/js/video-lightbox.js

    Open the file to edit. Scroll to the middle and you should see:

    $vid_lightbox_autoplay = 'false';

    Change 'false' to 'true'. Save and close. That should do it. good luck.

  3. wptipsntricks
    Plugin Author

    Posted 2 years ago #

    @gabevanlelyveld, thanks for the tweak.

  4. chadw1207
    Posted 2 years ago #

    Just an update to the prior post from @gabevanlelyveld.

    I was also trying to get the autoplay to work and it doesn't seem to in the shortcode using autoplay="true" or autoplay="1". I'm running v1.6.1 and there is a variable called autoplay that is set to false in video-lightbox.js. Changing it to true provides the desired result, but a plugin update will disable this.

    @wptipsntricks can this be accomplished in the shortcode?

    this is my current shortcode

    [video_lightbox_youtube video_id=tMfu5aSXU8U width=600 height=450 anchor="Watch Our Video"]


    Also on my phone it works, doesn't autoplay (I think the phone controls this), but the video overlay is quite small. Can this be made to fill to 100% of given screen size?

    Thank you for any assistance.

  5. 71lbs
    Posted 2 years ago #

    So I'm using the popup shortcode in a textbox (not sure if that's relevant) and it wont autoplay.

    in video-lightbox.js line 39, it reads: autoplay: (vlpp_vars.autoplay=="true") ? true : false,

    This is the shortcode I'm using [video_lightbox_vimeo5 video_id="99881817" width="960" height="540" anchor="/wp-content/uploads/2014/07/video-screen-shot-refund-due.png"]

    Not sure why the solved solution isn't fixing it. Any help/ideas is appreciated.

    site: http://www.71lbs.com/how-it-works

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic