Support » Plugin: Shiftee Basic - Employee and Staff Scheduling » Viewing your schedule

  • Just a quick question. I really love the plugin and will be upgrading to the full product to manage our employees schedule. I am having difficultly in setting up the plugin so that the employees can see their individual schedule. I created a page with the shortcode [your_schedule] but when a user logs in, the login page just resets. Does it need to be added to the menu in our website to be viewed? Any help would be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Morgan Kay

    (@gwendydd)

    This might have something to do with either your theme settings, or with some other login-related plugin on your site.

    Does this happen with all Shiftee shortcodes, or just [your_schedule]?

    Can you try disabling all other plugins, and see if the problem persists? If so, can you switch to another theme (such as TwentySeventeen) and see if the problem is still there?

    Thanks!

    Hi Morgan,

    Thank you for the reply. We do use a separate login plug in for our LMS so that might be the issue. Is there any workaround (menu, widget, etc.) that you can think of that would allow the employee to see their schedule a different way?

    Thanks again for the help!

    Jason

    Plugin Author Morgan Kay

    (@gwendydd)

    Hi, Jason,

    What login plugin are you using?

    Hi Morgan,

    We primarily use WordPress to run our Learning Management System (LearnDash) and we use a plug in called Uncanny Owl to give us additional functionality. Within the Uncanny Owl plug in is a log in redirect that takes our users to a specific page that welcomes them to the learning site. My guess is that the problem the employees viewing their schedule may have something to do with that.

    Thanks again for helping with this.

    Jason

    Plugin Author Morgan Kay

    (@gwendydd)

    Hi, Jason,

    It’s hard for me to provide advice without knowing exactly what the Uncanny Owl plugin does, or what your settings are.

    First of all, if you haven’t done so already, I suggest you either disable the Uncanny Owl plugin or turn off the redirect settings in Uncanny Owl to make sure that that is definitely the problem.

    You might need to make sure that employees are already logged in before they can get to any of the Shiftee pages that require login. Maybe make an “employee portal” page that has links to the schedule, and require login before they can view that portal page. That way, Shiftee won’t ask them to log in.

    If that doesn’t work, let me know – I might need to log in to your site to take a look.

    Thanks!
    Morgan.

    Hi Morgan,

    Thanks for the reply. I will try your suggestions. I was thinking of just creating a page with a link so I’m glad you mentioned that. It might be a simple solution and could work perfect for us. I’ll keep you posted.

    Jason

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.