WordPress.org

Forums

[resolved] viewers can't see images (17 posts)

  1. vermithrax423
    Member
    Posted 4 years ago #

    I did a search on google for this but the things i found didn't really help me. my website is at http://vermithrax.is-a-geek.com running wordpress 3.0.1 reflection theme with the yapb plugin. If i am on my own network i can view my page and pictures just fine. but when i connected to my neighbors network and tried to view it the page loads but not the images, i also had one of my friends that lives in florida try to view it and she got the same thing. was hoping that someone could help me... if you need any more information or find anything out please let me know.

  2. Deus
    Member
    Posted 4 years ago #

    I can't even load the website... :)

  3. Pranav Rastogi
    Member
    Posted 4 years ago #

    Hi,

    Your WordPress' installation URL is set to http://192.168.0.15. Change it to your website's url and it should work fine.

  4. vermithrax423
    Member
    Posted 4 years ago #

    yea i guess that would be part of the problem...
    ok so a little more information i have wordpress installed on my desktop running ubuntu 10.10, and am using dyndns.com for the vermithrax.is-a-geek.com . i do most of my editing from my laptop and on the same network as my desktop. When i am connected to my network i can see everything just fine, but then i connect to my neighbors network (or if anyone outside the network tries) in the browser i use to do all my editing on wordpress everything shows up fine (well last night the images weren't showing up but today it is working just fine), but if i open a different browser nothing really works so i think it has something to do with cookies and all that for the reason why it shows up in one browser but not the other.
    here is what the page should look like
    This is how it shows up outside my network

  5. Pranav Rastogi
    Member
    Posted 4 years ago #

    Err, you need to set the installation URL to http://vermithrax.is-a-geek.com/. There is also a blog URL which is different from installation URL. Check your WordPress settings.

  6. Deus
    Member
    Posted 4 years ago #

    Try changeing your images links from your website files from plain "/images/background.png" for example, to "http://yourwebsite.com/images/background.png".

  7. vermithrax423
    Member
    Posted 4 years ago #

    ok so i set the wordpress url to http://vermithrax.is-a-geek.com and when i click apply i get an error page that says the requested url /wp-login.php was not found on this server and now i can't get back into my wordpress admin page to change the setting back to how i had it...

  8. Pranav Rastogi
    Member
    Posted 4 years ago #

    Accessing http://vermithrax.is-a-geek.com/wp-admin gives a 404. Have you uploaded the files properly?

  9. vermithrax423
    Member
    Posted 4 years ago #

    if i put all my files in the root directory will this fix the problem? right now i have my index.php in /var/www/index.php and the rest of my files in /var/www/wordpress/... and in the index.php i changed the
    require('./wp-blog-header.php');
    to
    require('./wordpress/wp-blog-header.php');

  10. Pranav Rastogi
    Member
    Posted 4 years ago #

    Yes, transfer all yours files to /var/www/.

  11. Pranav Rastogi
    Member
    Posted 4 years ago #

    And revert your index.php back to how it was.

    require('./wp-blog-header.php');

    You're not supposed to edit this file.

  12. vermithrax423
    Member
    Posted 4 years ago #

    ok so i moved everything back into /var/www and i changed the index.php back, i was able to get back into my wp-admin and i got the wordpress address and the site address both set to http://vermithrax.is-a-geek.com i think the page is loading with the theme outside of my network now but im still not getting images to show?

  13. Pranav Rastogi
    Member
    Posted 4 years ago #

    Only 2 images are being sent. You need to add images for them to show.

  14. vermithrax423
    Member
    Posted 4 years ago #

    also dunno if this helps solve the problem or not but now when i go to post>new post for the yapb image i click choose file, pick the file i want and put in a title for the post, then i click publish, it loads for a few seconds then a blank page comes up that says nothing more than Error: File does not exists!

    but if i go back to my posts it shows that it posted and there is a thumbnail image of the image i selected...

    I haven't changed any of my media settings, uploads are still going to wp-content/uploads, full url path to files is still blank and the box is checked for organizing uploads by month- and year- based folders....

  15. vermithrax423
    Member
    Posted 4 years ago #

    Ive tried just usting the yapb image uploader in post then publishing the post... but the image doesn't show up. so i thought maybe if i went to media>add new and uploaded the images i wanted in my post thru the wp-uploader it would work, then once i uploaded the images i tried to attach them to the post they were associated with.... but its still not working... can anyone help me or point me to where i can get this resolved?

  16. vermithrax423
    Member
    Posted 4 years ago #

    ok i think i got the problem fixed... turns out that a lot of the problem was with the theme i was using, i changed the theme and now it seems my pictures are showing up just fine... thanks for everyones help especially Pranav Rastogi

  17. sultan1994
    Member
    Posted 4 years ago #

    Hi guyss i have launched a new website: http://www.technoconvoy.com
    and it is amazing and mindblowing. guys i need web traffic so please
    help me. do visit my website. plzzzzz guys i need your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags