WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] "View order" link/button shows "My account" page (6 posts)

  1. emielm
    Member
    Posted 1 year ago #

    All links and endpoints are working fine on my site, but the links/buttons on the my-account page are not working as they should: After clicking these the "My account" page is shown, instead of the order details page. The slug/my-account/view-order/orderID is correct though. Any idea what's causing this?

    https://wordpress.org/plugins/woocommerce/

  2. askingwoo
    Member
    Posted 1 year ago #

    I'm having similar situation.
    After clicking the "/my-account/view-order" link, the screen refreshed, but still shows my-account page.
    It doesn't move to view-order page.
    The other endpoints work perfectly.
    I've deactivate every other plugins and flushed permalink several times.
    But it didn't work.
    Any help, please?

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    @askingwoo: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  4. askingwoo
    Member
    Posted 1 year ago #

    Sorry. I didn't know that's impolite... I'll post new thread.

  5. emielm
    Member
    Posted 1 year ago #

    I figured out what was causing this behaviour on my website: It's was user logged in shortcode that was causing this. Changing the my account page to another url solved it for me.

  6. Ken2000
    Member
    Posted 4 months ago #

    cheers emielm, I got the similar issue which was the wrong page was selected for account page in Woocommerce->account. So when user click the view order button it never works, everything are sweet now as soon as I select the appropriate page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.