Support » Plugin: Google Website Translator » View only flag

  • Resolved kingdave

    (@kingdave)


    Hi,

    I would like only flags to be displayed but I can’t find this solution among the available layouts! The google layout is always proposed to me.
    I use elementor and I don’t understand how mail the widget doesn’t work in the header but only in the pages or in the popups.
    Until a few months ago I was using it quietly on another site.

    Do you have any suggestions? Thank you

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Prisna

    (@prisna)

    Greetings,

    You can show only the flags by going to:

    General > Show flags over translator > Yes

    Then:

    Advanced > General > Custom CSS

    Use:

    #google_translate_element {
      display: none !important;
    }

    Regards

    Thread Starter kingdave

    (@kingdave)

    wonder!!!!

    Your support is TOP!!!!!

    Thank you

    P.S. Have a solution also to show flag on elementor header section?

    Thread Starter kingdave

    (@kingdave)

    I take advantage!

    But why does the top bar of google always appear for where it tells me what language I translated from, the button shows original and the options? Can’t I avoid it? I put the check on the don’t display transaction banner … but it always appears !!!

    Plugin Author Prisna

    (@prisna)

    P.S. Have a solution also to show flag on elementor header section?

    It depends if it’s possible to add a shortcode or a widget in that header section. If so, then place the translator there.

    As for the other message, please send a link.

    Regards

    Thread Starter kingdave

    (@kingdave)

    http://www.studiobrandelli.it

    for login use:

    user: test
    password: studiobrandelli

    i use a popup for language select and banner is even show!

    thank you

    Plugin Author Prisna

    (@prisna)

    The user/password combination doesn’t seem to work.

    Please either send a link where the site can be seen, or double check the login information is correct before sending it again.

    Thread Starter kingdave

    (@kingdave)

    user: test
    password: brandelli

    it work!

    Please retry!

    Thread Starter kingdave

    (@kingdave)

    test
    brandelli

    Plugin Author Prisna

    (@prisna)

    Thanks, it works now. You should go to the plugin’s settings, and then to:

    Advanced > General > Custom CSS

    Use:

    .goog-te-banner-frame { 
    	display: none !important;
    	visibility: hidden !important
    }

    Regards

    Thread Starter kingdave

    (@kingdave)

    thanks but not work!

    in Custom CSS i’ve this:

    #google_translate_element {
    display: none !important;
    }

    .goog-te-banner-frame {
    display: none !important;
    visibility: hidden !important
    }

    And bar is showed!!!!

    I don’t understand!!!
    Is it because widget is in a popup?
    I prefer insert it oh header but widget or shotcode not work on Elementor header!!!

    Please give me a solution!!!

    Thanks

    Plugin Author Prisna

    (@prisna)

    The popup destroys its content (the translation widget along with the CSS rules) when it’s hidden, that’s why the top banner doesn’t show up while the popup is visible.

    You should place the CSS rules somewhere else where they don’t get deleted. Most themes have a Custom CSS field within their settings.

    Thread Starter kingdave

    (@kingdave)

    I think it is a problem with the code provided.
    Either if I insert it on the css setting of the astra theme, or if I insert it on elementor’s css or as a snippet in my plugin for managing snippets … it gives me an error … it does not expect dot characters and characters } and {

    Thread Starter kingdave

    (@kingdave)

    you can try
    bar not appear but it’s space remain occupied by blank!!!

    Thread Starter kingdave

    (@kingdave)

    however I have to find a solution to run it on the head of the site because when I access pages other than the home I no longer have the active translation !!!!

    Thread Starter kingdave

    (@kingdave)

    It’s all right now!

    Shortcode on elementor header and all problems are solved!

    I hope that all work!!

    Thank you!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘View only flag’ is closed to new replies.