• Resolved moviepen

    (@moviepen)


    What’s the best way to collect metrics for poupus? Namely how many times an individual popup has been displayed to the users. Click tracking and close tracking I have figured out — it’s just how to measure each popup’s view numbers

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @moviepen,

    We have released completely rewritten version of the plugin and now it tracks conversion and view count for you directly in plugin so check it out and let us know how you like it 🙂

    Cheers,
    Predrag

    I’m eager to try it. When I used the “Upgrade now” feature from the plugin from the WP admin screens, it broke the site, with the following error:

    Parse error: syntax error, unexpected T_FUNCTION in /home/content/61/7314161/html/testsite/wp-content/plugins/wordpress-popup/inc/opt-in-front.php on line 83

    Since it caused the site to crash, I deleted the plugin, and tried installing Hustle directly. That refused to activate with the same error:

    Parse error: syntax error, unexpected T_FUNCTION in /home/content/61/7314161/html/testsite/wp-content/plugins/wordpress-popup/inc/opt-in-front.php on line 83

    Hopefully this helps troubleshoot — I’m looking forward to the update!

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @moviepen,

    I’m sorry to hear you have this issue.

    I can’t replicate the same on my installation. Would you please let me know what is the PHP version running on your server? If it is lower that version 5.6 please upgrade it to a higher version. WordPress recommends using version 7.0:
    https://wordpress.org/about/requirements/

    Please advise,

    Kind regards,
    Nastia

    I’m running my server on GoDaddy, which does not support PHP 7 for me. They are only allowing up to PHP 5.4 at this time; PHP 7 isn’t available to anyone on GoDaddy, as far as I understand it, at the moment.

    If upgrading the php is the only solution, please let me know, so I can step back from Hustle. PHP7 is simply not an option for my situation.

    Thanks.

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @moviepen

    I’ve just tested the plugin with PHP ver 5.3 and PHP 5.4 and can’t replicate the same. The plugin is working well from my end.

    Would you please run a quick check for a conflict with another plugin or theme.

    Deactivate all other plugins and try to install and activate the Hustle – Pop-Up. If everything is well, activate one plugin at a time to find the one that causes this.

    Let me know how it went!

    Kind regards,
    Nastia

    When I turn off all plugins and updated the plugin, I got the same error; it crashed the site, and I couldn’t get to the admin database. I deleted the plugin folder, and then installed Hustle directly. I still got that same error, but it didn’t crash the site.

    On further delving, my site’s running on php 5.2. If you still feel it’s related to PHP versions, I will have to put this on hold since I can’t push up to a later version quite yet.

    Thanks again for your continued help.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @moviepen,

    I’m afraid that PHP 5.2 is indeed the cause here as I was able to replicate this issue on one of my sites when switching to 5.2.

    Hustle at this moment supports PHP 5.3 and up but our devs are looking into resolving this specific issue for 5.2 and hopefully we’ll see it addressed in next release.

    Cheers,
    Predrag

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘View metrics’ is closed to new replies.