Support » Plugin: Custom Post Type UI » View link missing for CPT

  • Resolved relish1227

    (@relish1227)



    Hello,
    I’ve got a CPT called “partner” and I just noticed that it’s missing a) the “View” link in the default actions within the admin area list of partners and b) when I edit a partner, it’s missing the permalink.

    I’m also using ACF, but I have tried deactivating that plugin plus everything else and also changing to the 2017 theme.

    I noticed this issue because I was testing out my search results and trying to see what happened for each CPT on the site. For the partner CPT, it does generate a URL (like this http://mywebsite.com/partner/partner-name/), but going to it redirects you to the home page. I don’t believe I have any special redirects set up, either.

    I’m wondering if I have some Custom Post Type UI setting in place that’s causing this — but I may not be familiar enough with the settings to understand which one. Comparing with my other CPTs (which do have the view links and work properly with single templates), nothing is standing out.

    Any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    Did you customize the “capability type” field away from “post”? It sounds like possibly a “read” permissions error, off the top of my head.

    relish1227

    (@relish1227)

    Nope, I never change that. It’s still set to “post.”

    Plugin Author Michael Beckwith

    (@tw2113)

    Hmmm. Not quite sure what’s going on then. Would you be willing to share your settings so I can see if I can recreate at all on my end?

    You can get them either via Tools > Post Types tab, or via Tools > Debug Info. If choosing to use the “Debug Info” version, for the sake of not publicly publishing some of that info, I’d recommend emailing that to me via the small text field below it. You can use michael @ webdevstudios . com for that. Either section from the tools menu will work fine though.

    relish1227

    (@relish1227)

    Sure, I’ll send you an email. Thanks!

    Plugin Author Michael Beckwith

    (@tw2113)

    Received and reviewing. Thanks.

    Plugin Author Michael Beckwith

    (@tw2113)

    The “Publicly Queryable” parameter being set to false did you in. That’ll need to be set to true to see the post on the frontend.

    relish1227

    (@relish1227)

    A-ha! I’m glad to have the mystery solved re: the missing view link.

    As I’m actually displaying all of the partners on one page and don’t need to use the single template, this is kind of how I wanted it to behave… They *are* showing up in searches, which is interesting given this setting. But I’d rather redirect visitors to the page they live on vs. redirecting to the home page. So I think I’ll put this set to true but then do my own regex redirect to the partners list page.

    Thanks!

    Plugin Author Michael Beckwith

    (@tw2113)

    Use the “Exclude from search” setting if you don’t want them showing up there. The publicly queryable detail relates to WordPress as a whole when viewing on the frontend, not just search queries. 🙂

    relish1227

    (@relish1227)

    Got it. Thanks for clarifying!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘View link missing for CPT’ is closed to new replies.