Support » Plugin: YITH WooCommerce Wishlist » /view/ is beeing added to the end of wishlist page’s url

  • Hi,

    I have an issue with a strange behaviour after adding a product to the wishlist.

    Right after the confirmation message about the product beeing successfully added, the url of View my Wishlist changes to http://www.domain.com/my-wishlist/view/M8IVNNYQSOCY/
    If I repeat it with another product, I get the same url again and again, but sometimes the url changes to only to http://www.domain.com/my-wishlist/view/

    Both are invalid urls and respectively 404s. The correct url is http://www.domain.com/my-wishlist/

    At the same time loading of the real wishlist url directly within the browser works properly.

    You can make a test here.

    Any advice how to fix it is greatly appreciated!

    *Update: It appears that this conserns only to logged WordPress users.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well! 🙂

    I have been trying to replicate the issue on a local site but unfortunately, the wishlist links are working in the right way.

    Please, could you change your active theme to a WordPress theme like ‘Twenty Sixteen’ and check if the problem persists?

    Let us know.

    Have a great day!

    trobinson33

    (@trobinson33)

    Hello,

    I am experiencing the same issue as TheGreyRabbit Describes.

    When logged in and adding a product to the wishlist the url then adds /view/randomstring which leads to the wishlist page but it is empty.

    Again this is effecting logged in users.

    I have tried switching themes to ‘TwentySixteen’ and experience the same issue.
    Also have tried to deactivate all plugins except Woocommerce and YITH Wishlist and experience the same issue.

    https://sweetandsprouted.com

    Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well! 🙂

    Please, make sure you have your wishlist page created and selected in the plugin options and save the changes (Take a look here, please).

    Let us know, please.

    Have a great day!

    Hello,

    the wishlist page is selected here.

    Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well 🙂

    The problem could be related to permalinks. Please, try to update them.
    Go to Settings -> Permalinks -> Save changes

    Let us know.

    Have a great day!

    I have selected the wishlist page / updated permalinks and experiencing same issue.

    The same here

    Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well! 🙂

    Could you change to a default permalink structure and check if the problem persists, please?

    Let us know.

    Have a great day!

    Hello,

    I have changed my Common Settings permalink structure to plain and Product permalinks to default and still experiencing the problem.

    Any progress on this issue?

    Plugin Author YITHEMES

    (@yithemes)

    Hello there,

    hope you are doing well 🙂

    We have been trying to do some tests, to try to get some 404 error but unfortunately, we can’t replicate it in any way.

    You can check in this screenshot that the URL is generated with /view/random_string (that is the correct behaviour) and we don’t get any error.

    We suggest you try to install the plugin in a clean installation and check if the problem persists.

    Have a great day!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘/view/ is beeing added to the end of wishlist page’s url’ is closed to new replies.