Support » Plugin: DB Toolkit » View Interface -> Add Entry -> Save doesn't update DB in 3.5.1

  • Resolved davefwood


    Plug-In Version:
    WP Version: 3.5.1

    What I did:
    1. Started new app = good
    2. Added new interface [using new table] = good
    (default record id, User ID [auto-increment], sitename [text], type [drop down select])
    3. Save = good
    4. View Interface -> Add Entry -> [fill in form] -> Save = No result.

    What I found:
    The table is there.
    If I use phpAdmin to insert a record, it shows in the refreshed View Interface screen.
    If I use the Add Entry button again, the Form opens populated from the failed Save. (Caching?)

    Other stuff that might matter:
    I set up a custom theme before I installed & activated the plug-in.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hmmm. I tried it in 3.4.2 as well.

    Okay, what am I doing wrong?

    Reinstalled 3.5.1 and now it works. Maybe there was a conflict with some plug-in(s) I left out of the reinstall?

    Anyway, it works and I’m really impressed. Looking forward to rating it after after I’ve worked with it a bit more.

    Plugin Author David Cramer


    Glad you got it sorted and like the plugin. I hope you find it useful.

    I’ll try be here more to help out when i can.

    I’m having this exact same issue. This is with a vanilla WP 3.5.1 install with no plugins or themes just default twenty twelve. I am using 0.3.3 of DB Toolkit. I was having the same issues with the previous version as well.

    I have also tried WP 3.5.2 with the same results. I have yet to get this to properly work. I have also done the exact same debugging/test as the OP, if I add records to the table through an external DB app, DB Toolkit will correctly pull that data in the WP UI. But adding a new entry through the WP DB-Toolkit interface does not work.

    The jQ UI Dialog widget popup shows when you click “Add Entry” and the fields display, saving closes the popup and then nothing happens, no consol logs, no script/post errors. I have also noticed the “caching” of a failed entry attempt displaying when reattempting to insert a record.

    Plugin Author David Cramer


    Do you have it online where I can give it a test run?

    I do. Any way to PM the details?

    Plugin Author David Cramer


    Email me at

    Plugin Author David Cramer


    Well, I found the bug.
    You can’t set the auto values to be required. Since it’s an auto field, there is no value submitted. The validator checks that values are provided before inserting into the db and since an autovalue is created on insert, the validator rejects the input before getting to that point.
    I’ll make a patch for the next update. For now just don’t set autovalues to be required.

    Great. Thanks a lot

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘View Interface -> Add Entry -> Save doesn't update DB in 3.5.1’ is closed to new replies.