Support » Plugin: WP-PostViews » View Counts stoped working

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Lester Chan


    You sure it stopped counting or the display of the views is cached? You can check the count of the post in the custom meta field under the edit post screen to see if it increases when you visit the post.

    It’s stopped! Custom field under posts is the same as All Posts on WP Panel and the same on site post page…

    It start counting only if I disable W3TC! (Version 0.9.3 ) :/


    Plugin Author Lester Chan


    What is your site URL? I want to check the AJAX request

    I forwarded you the link on Google-Hangouts!

    I just notice also that, the_views(); is returning an empty string!

    sorry, the_views(); is working!

    Rolling back to older version of W3TC and I’m checking if it works!

    Is not counting either with W3TC Version

    Plugin Author Lester Chan


    I don’t use Google Hangout much, just paste the link here.

    Here is the page link

    Thank you!

    Plugin Author Lester Chan


    the plugin is not activated on your site ether that or WP_CACHE is set to false which contradict your first statement.

    Really strange, because both plugins are activated!

    <!-- Served from: www. .com @ 2013-10-08 18:09:36 by W3 Total Cache -->

    The same issue i have on another site.

    Plugin Author Lester Chan


    I am not too sure what happen in your case, if WP_CACHE is set to true, the plugin will inject a JS code to your header. But for your case the JS header is nowhere to be seen. I did a search for .js file in your header, beside your theme default .js file, it seems no other js file is in it.

    Try on the default theme to see?

    I think I solved! The problem was under jQuery!

    Thanks for you time and for the great plugin 🙂

    Pleaze CrossX could you post your solution!

    The problem was under jQuery!

    What’s that?

    I am having the same issue, not counting the posts view when w3 cache plugin is activate. More precisely I discover that minify is the culprit.


    Make sure the jquery is loaded on the header before all others js calls!

    edit: esclude jQuery from minify!

    Thanks! But how?

    Meanwhile I discovered that, using the Minify: Help Wizard, and unchecking all the JavaScript files embeded in <head>, the counting works. Btw, I let checked all the following Cascading Style Sheets.

    Minify Help wizard: To get started with minify, we’ve identified the following external CSS and JS objects in the theme. Select “add” the files you wish to minify, then click “apply & close” to save the settings.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘View Counts stoped working’ is closed to new replies.