Support » Fixing WordPress » Video won’t autoplay on homepage

  • Hi,

    The vimeo content embedded on the top of my home page used to automatically play but now it won’t. This is what I’ve written into my loop-index:

    <div class="twelve columns" style="margin-bottom: 40px;">
    	<iframe src="https://player.vimeo.com/video/279929631?autoplay=1&loop=1&color=ffffff&title=0&byline=0&portrait=0" width="980" height="400" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
    </div>
    <div class="twelve columns">

    Does anyone have a fix for this?

    Cheers

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Are you only testing this in Google Chrome? Chrome no longer supports auto-play videos.

    I’ve checked the site in Safari browser and it does indeed still auto-play.

    • This reply was modified 7 months, 1 week ago by  tomreed25.
    jhners

    (@jhners)

    That’s interesting because it isn’t autoplaying in my safari… Not sure what to make of this.

    jhners

    (@jhners)

    Also, if the video has no sound, it should still work. I intentionally uploaded my video with no audio so Chrome would still autoplay but no joy.

    • This reply was modified 7 months ago by  jhners.
    • This reply was modified 7 months ago by  jhners.

    it seems the video is auto playing even on Google Chrome what was the fix??? I’m having the same issue on Chrome yet other browsers are playing the video on autoplay function. Please let me know. Thank you.

    Hey!

    I ended up downloading a free webpage builder plugin called ‘Elementor’ which is really intuitive & simple to use.

    https://en-gb.wordpress.org/plugins/elementor/

    Once installed, create your page, insert a video, paste Vimeo / Youtube URL into the left sidebar, then in the video options toggle ‘autoplay’.

    Hope this works.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.