Support » Plugin: Videopack (formerly Video Embed & Thumbnail Generator) » Video Thumbnails of other languages vanish from gallery after translating video

  • Resolved michelyweb

    (@michelyweb)


    Hi,

    Polylang Pro plugin is used for translating posts and media. As soon as i translate a video in another langugae, the video thumbnail of the video of the other language is no more shown in gallery. instead it shows the default fallback thumbnail from settings.

    I tried enabling and also disabling “Set generated video thumbnails as featured images.” but it changes nothing.

    Next i tried to copy and paste the video thumbnail url from the video in default language to the translated videos. But same problem as before.

    I feel like a cat chasing its own tail…
    Any Ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Kyle Gilman

    (@kylegilman)

    What does it mean exactly when you translate a video in the Polylang Pro plugin? Is it adding captions or subtitles or translating some metadata attached to the video? Can you post a link to a page on your site that demonstrates the problem?

    Thread Starter michelyweb

    (@michelyweb)

    @kylegilman thanks for your reply.

    What does it mean exactly when you translate a video in the Polylang Pro plugin? Is it adding captions or subtitles or translating some metadata attached to the video?

    “Translating a Video” just means a simple translation of the attachments “title” and “caption”. There are no change in videocontent or subtitles.

    See Screenshot: https://dsh.re/e22379

    Can you post a link to a page on your site that demonstrates the problem?

    Here’s a video: Video Link

    The Video Attachments are “translated” already. And as you can see the relation from the translated post is set to the translated video-attachment.

    Pleas ask further questions, if needed. I appreciate your help.

    Best,
    Marco

    Plugin Author Kyle Gilman

    (@kylegilman)

    You’re not using my video player on this page https://www.loom.com/share/88e52759ae71435ca0111973164d917e so I don’t know what kind of support I can provide.

    Thread Starter michelyweb

    (@michelyweb)

    @kylegilman in the linked video i show you the problem… The page url where you can see the actual website i am working on is https://litec.derweb.space/produkte/litec-400/

    Plugin Author Kyle Gilman

    (@kylegilman)

    Sorry, I didn’t understand that you had done that whole screen capture in the video. That was useful, but as always I learn more from a live page. Something in this process is duplicating the video attachments and saving them under different IDs. I suspect the translation plugin saves each translation using a different ID in the database. When you generate a thumbnail using my plugin, it is assigned to a particular video ID so when you switch languages you don’t see the thumbnail anymore because my plugin doesn’t know it’s the same video. Since the Polylang Pro plugin is a premium plugin I can’t really get under the hood and figure out how it works. If there’s any way you can find in the Polylang settings to disable that particular function I think it would solve your problem.

    Thread Starter michelyweb

    (@michelyweb)

    Hi @kylegilman if i disable the Polylang Media Translation feature, i have to upload the same video again for each language so that the client can enter ‘title’ and ‘caption’.

    By the way: Disabling media translation changes nothing.

    I do not understand, why i not just can copy the thumbnail path to each language-specific video file.

    The generated thumbnail path is for example /wp-content/uploads/v13_thumb2.jpg
    Maybe the problem is that the video file name on the (translated) attachments is the same?

    Uploading the _same_ Video with another file name (e.g. vid12_en.mp4) seems to work. But it’s a lot of work and increases the space needed. We’ve four languages. The Videos are without narration, so one file and translating the fields only would be the better solution for my client.

    • This reply was modified 7 months, 2 weeks ago by michelyweb.
    • This reply was modified 7 months, 2 weeks ago by michelyweb.
    Plugin Author Kyle Gilman

    (@kylegilman)

    I’m starting to get to the bottom of the problem. All of the logic around creating thumbnails was based on the idea of unique filenames for each video. If you had saved a thumbnail but then changed your mind and generated a new thumbnail with the same filename I wanted to make sure you could replace it smoothly. But in your case if you create a thumbnail and then copy and paste the URL to another video with the same filename before the temporary files created by the plugin are cleaned up, the plugin will delete the existing attachment from the database and create a new one with the same metadata but a new post ID. It’s an edge case I never planned for but I should have a fix for it soon.

    Thread Starter michelyweb

    (@michelyweb)

    Thanks, @kylegilman!
    For now i have to upload each video with different filenames to get the project finished.

    It’s an edge case I never planned for but I should have a fix for it soon.

    I see. Thanks for your excellent support!

    Plugin Author Kyle Gilman

    (@kylegilman)

    I think this was fixed in today’s release of version 4.7 but I wasn’t able to test it with the translation plugin so I’m not 100% sure.

    Thread Starter michelyweb

    (@michelyweb)

    Thank you @kylegilman – I will test this asap.

    Thread Starter michelyweb

    (@michelyweb)

    I’ve tested the updated version with Polylang Pro and it works perfectly now! Thank you very much @kylegilman. You will receive a German beer for free.

    Plugin Author Kyle Gilman

    (@kylegilman)

    Great news! This was a tricky problem caused by some fundamental issues with how thumbnails were saved by the plugin for the past ten years.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Video Thumbnails of other languages vanish from gallery after translating video’ is closed to new replies.