Support » Fixing WordPress » Video Thumbnail images using SiteBuilder

  • Resolved Joshjj

    (@joshjj)


    Hi. I’ve installed the Page Builder plugin by SiteOrigin. I want to create a video portfolio page s
    I’ve added a double column, added video widgets and uploaded my videos but all I see are black video players with no thumbnails images

    Is it possible (using SiteBuilder) to add thumbnails images (and text) to these videos to show before they are clicked on? Or whole I have to go into the code?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Josh,
    It looks like the Video Widget should ask you for a ‘Poster Image’ which is the technical term used to refer to the video thumbnail.
    https://siteorigin.com/widgets-bundle/video-player-widget/

    Unfortunately those won’t be automatically generated – but if you create thumbnail images for each, and upload it to the ‘Poster Image’ field then it should use it instead of the plain black box.

    Thanks a lot! I’ve tried different settings in the “Background Image Display” drop-down menu and I’m getting a weird result. It’s showing the top half of the thumbnail image ABOVE the video, behind the video Title. Its not actually putting ht image over the video as it should be.

    See video on top left of page:
    https://cashmerestudio.000webhostapp.com/video

    Does the thumbnail image have to be a certain size/dimension to match the video player, or will it be stretched to fit? If so, what dimensions to I need to format the image to?

    Bump

    Right, now I know why I was getting a ‘weird’ result – because I was using the “Background Image” display.

    The confusion here was that the Video widget supplied with the PageBuilder plugin doesn’t (as far as i can see) supply a cover/thumbnail image option. You have to install and use the Video widget from the SiteOrigins Widgets Bundle plugin! Not sure why this is the case but anyhow.

    • This reply was modified 1 year, 5 months ago by  Joshjj.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Video Thumbnail images using SiteBuilder’ is closed to new replies.