Support » Plugin: Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream » Video playlist not playing on safari (mac osx)

  • Hi,
    We have a video gallery playlist on our website.. it works just fine on all browsers except the safari browser on mac.
    the error on gallery thumbnail click is as follows:

    Failed to load resource: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error -10.) data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=&autoplay=1

    this error is shown when the thumbnail on the gallery view is clicked.. the main video works fine though.

    website: http://www.hup.edu.pk

    https://wordpress.org/plugins/youtube-embed-plus/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author embedplus

    (@embedplus)

    Ow33,

    It’s actually more than Safari/Mac. The root problem is the WP Rocket Rocket improperly applying lazy load on the YouTube video. Luckily WP Rocket’s team provides external developers like us a way to make their plugin leave YouTube videos alone.

    We’ve quickly uploaded the necessary change in the current version of our plugin (YouTube 11.4), so if you uninstall our plugin and reinstall it from wordpress.org, (and clear all your caches caches) it should work.

    Don’t worry, we’ve made sure that your YouTube settings will be preserved when you uninstall/reinstall.

    -EmbedPlus Team

    thanks that worked!

    but now for some reason its ignoring the height? when i inspect the div, it is adding padding-top: 59.74025974025974% !important; on .fluid-width-video-wrapper class.
    i checked the fitvids.js and found this:

    var fwvwrap = document.createElement('div');
                    fwvwrap.className = 'fluid-width-video-wrapper';
                    try {
                        $this.wrap(fwvwrap).parent('.fluid-width-video-wrapper').attr('style', 'padding-top: ' + (aspectRatio * 100) + "% !important;");
                        $this.removeAttr('height').removeAttr('width');
                    }
                    catch (wraperr) {
                    }

    i removed :
    $this.wrap(fwvwrap).parent('.fluid-width-video-wrapper').attr('style', 'padding-top: ' + (aspectRatio * 100) + "% !important;");

    and from fitvids.min.js i removed:
    a.wrap(e).parent(".fluid-width-video-wrapper").attr("style","padding-top: "+100*c+"% !important;")

    but its still adding the padding. i did cleared the cache though.
    can you please point out why this keeps adding the padding?

    Plugin Author embedplus

    (@embedplus)

    First, we strongly recommend not modifying the plugin. Future updates will just overwrite any changes you make.

    As for the padding, it’s actually part of a mechanism that enables your videos to be responsively sized. If you don’t want your videos to be responsive, then just uncheck the “Responsive video sizing” option(s) in the plugin settings instead of modifying scripts.

    -EmbedPlus Team

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Video playlist not playing on safari (mac osx)’ is closed to new replies.