Support » Plugin: S3 Video Plugin » Video player error – stream not found

  • Resolved lathayn


    I keep getting an error when trying to play my embedded video.
    I have my bucket in AWS set up correctly I believe because the videos show up under S3 existing media in the plug-in. I have tried using the short code as well as the embed code. I have also tried different types of files – I started with a .mov and then tried a .mp4 to make sure it wasn’t the file type. Both show the same error code: 200 ,stream not found, found, clip: {clip} http:….(this is the filename). Does the file name have to be a certain way – like no spaces or something?

    Also, I thought I would try the other player in the S3 settings – instead of Flowplayer, I tried videoJS – but nothing changed after I chose that – in other words, nothing in the embed code changed to say videoJS, it still says FlowPlayer, so I changed it back to FlowPlayer in the settings.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Anthony Mills


    Hi Lathayn,
    I would recommend getting rid of any spaces in the file name / bucket name and other non numeric characters with the exception of dashes -_ as the file is formatted as a URL.

    If you have are using firebug and have the firebug extension installed look under the net tab for the request made to S3 for the video file, take the location and try to open in a new tab this may shed some light on why the video cannot be retrieved.

    Also are you embedding using the shortcode or the flash object embed? This is intended for embedding videos outside or WordPress for debugging etc and should be used when inserting videos within wordpress.

    Kind Regards


    I got rid of the spaces and non-numeric characters and it still won’t play. It just keeps loading.
    I do not have access to firebug or know what it is.
    I have tried using the shortlink and the embed code, neither works. I am using WordPress.

    Plugin Author Anthony Mills


    Hi Lathayn,
    I think the best option is to take the plugin out of the equation altogether for the time being and find out why the file is not loading from S3. Get the object embed code from the wordpress backend. It will look similar to:

    <object width=”640″ height=”380″ id=”s3EmbedVideo” name=”s3EmbedVideo” data=”” type=”application/x-shockwave-flash”><param name=”movie” value=”” /><param name=”allowfullscreen” value=”true” /><param name=”allowscriptaccess” value=”always” /><param name=”flashvars” value=’config={“clip”:{“url”:”″, “autoPlay”:0,”autoBuffering”:0},”canvas”:{“backgroundColor”:”#112233″}}}’ /></object>

    Copy the value for the “url” parameter near the end, in this example its Take this url and then post it into a browser, it will most likely show and error, possibly not found? or it may may be and S3 error indicating the read permissions are not set on the bucket or the video.



    Hey Anthony, thanks for the tip, I know you were discussing troubleshooting the s3 implementation, but I actually like your code with flow player better than the s3 video plugin because it is easier and actually works for me.

    So here is my question:

    Can you provide insight on how I might set a poster frame for a specific video using this implementation of flow player? I have looked at their documentation but cannot get it to jive with how you’re setting up this object.

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Video player error – stream not found’ is closed to new replies.