Support » Plugin: Page Builder by SiteOrigin » Video Player broken in full screen

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi, thanks for reaching out. I can play the video in fullscreen using Firefox on iOS. Which operating system are you testing on?

    Thread Starter peopleinside

    (@peopleinside)

    Android 11
    Firefox developer 90.0a1

    When I put the video on full screen the video is rotate horizontally and the screen is black.

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks. I’ll have Alex take a look on Android. In the meantime, please, try creating a test page, insert the video into the Classic or Block Editor using a regular media embed, is the result different?

    Thread Starter peopleinside

    (@peopleinside)

    Yes, is different if I use the YouTube embed code.
    If you see in the page I mentioned there are two videos, the second has been added with YouTube Embed code.

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    I’ve run some tests and I’ve been able to replicate this issue. oEmbed uses the media player bundled with WordPress (MediaElement.js) and unfortunately, we don’t have much control over that script so this isn’t something we’re able to directly resolve this issue. I recommend reporting this issue to WordPress.

    You can continue to use the SiteOrign Video Player while avoiding this issue by disabling the Use oEmbed setting in the Video Play Settings group.

    Kind regards,
    Alex

    Thread Starter peopleinside

    (@peopleinside)

    Hi Alex, thanks for the reply.
    Where I can change the settings? I’m unable to find. I’m using Italian language tried to look in page builder settings but cannot understand what I need to change.

    Thanks.

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    The Use oEmbed setting is a SiteOrigin Video Player widget setting, and it’s in the Video Playback settings group. Here’s a screenshot:

    Kind regards,
    Alex

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    Sorry, it looks like the link didn’t come through. Here it is again:

    https://i.imgur.com/sHLI9fX.png

    Kind regards,
    Alex

    Thread Starter peopleinside

    (@peopleinside)

    Thanks for the answer. How I can reach this settings screen?
    I’m looking for but cannot figure out how to arrive there.

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    Ah. I just noticed you’re using the Video widget instead of our Video Player. Please open your website and navigate to Plugins > SiteOrigin Widgets and activate the Video Player widget.

    Open https://blog.peopleinside.it/2021/05/20/depurazione-energetica/ in the editor and remove the Video widget. Add the SiteOrigin Video Player widget and set the Video Location to Externally Hosted. Add the YouTube for the video to the Video URL field and then untick the Use oEmbed setting in the Video Playback settings group.

    For more information the SiteOirgin Video Player widget, I recommend giving the documentation a quick read.

    Kind regards,
    Alex

    Thread Starter peopleinside

    (@peopleinside)

    Thank you for the help, you done an amazing job by supporting me in very fast and active mode. I’m really shocked, thank you!

    Ah. I just noticed you’re using the Video widget instead of our Video Player. Please open your website and navigate to Plugins > SiteOrigin Widgets and activate the Video Player widget.

    I tried your video player but the look was not nice as the video was inserting very big, not looks nice in the page. Maybe there are some where settings to decide size but too hard for me.

    I resolved in a different way: I insert the video tin the text widget.
    Thank you very much for your precious help!

    Stay safe and have a great week end.
    Closing this as solved.

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    Great to hear you were able to get it working in a manner that you’re happy with. 🙂

    Our widget can also display using the same media player (this is done by ticking the Use oEmbed setting), but unfortunately, that’ll result in the same underlying issue as it’s a general WordPress (or MediaElement.js) issue.

    Have a good one mate.

    Kind regards,
    Alex

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Video Player broken in full screen’ is closed to new replies.