Support » Plugin: Video Embed & Thumbnail Generator » Video not playing on smartphones

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Kyle Gilman

    (@kylegilman)

    Can you post a link to a video that demonstrates the problem?

    Thx for quick reply, I forgot the link : https://www.lenaelle.fr/mon-voyage-a-santorin/

    Plugin Author Kyle Gilman

    (@kylegilman)

    This is specific to the new autoplay/muted video policy in iOS. Was there a time when this did work on iOS? Was it working with an older version of my plugin? Does it work on some devices but not others?

    I was able to get only the first video to play on my iPad, but none of them play on my iPhone 6. I found a confirmed webkit bug that prevents more than one video from playing. On the iPhone if I added the new playsinline attribute to videos that weren’t muted, I could hear the audio but couldn’t see the video so I think playsinline is not working well. It looks like playsinline is assumed on the iPhone with any autoplay videos since you wouldn’t want them popping up into fullscreen. I think it’s possible that the first video is playing on your iPhone but you can only see the first frame, which of course is the same thing as not playing at all. On my iPhone 6, I’m also not seeing any animation in the video at the top of the page that announced the new policy. Does that one work for you?

    Plugin Author Kyle Gilman

    (@kylegilman)

    Thinking about this problem again, I was reminded that we came up with a fix for this 6 months ago but I modified it to allow the controls to stay disabled on muted videos after iOS 10 came out because I thought it was working now. It does work on Android, and it works in the iOS simulator, but a real-world iPhone 6 doesn’t work. I haven’t had the opportunity to test it with a newer iPhone, have you?

    You totally right, I hacked the plugin with the linked changes (other ticket). I’ll try to readd them to see if something is happening 🙂

    Thx for the reminder.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Video not playing on smartphones’ is closed to new replies.