Support » Plugin: All-in-One Video Gallery » Video not playing in detail page

  • Resolved karthickr

    (@karthickr)


    Hi Team,

    I can see all the features in your plugin. So, I have installed the All in one Video Gallery plugin(1.6 version) in the WordPress version of 5.0.3

    As per the procedure, added the new videos and categories under the Video Gallery. All the videos are listed on the main page.

    But, Video is not working on the detail page, I have used the below items in the video sources as
    Video Type: YouTube
    Video Link: https://www.youtube.com/watch?v=JS9anVQ

    After loading page, I have seen only the black display screen like the below snap

    In the console, I saw the iframe src url like {domain}/player-embed/id/4385

    Is there anything wrong from our side? Please help me to solve this issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author plugins360

    (@plugins360)

    The YouTube Video URL you’ve configured is invalid https://www.youtube.com/watch?v=JS9anVQ

    Please click at the URL and you should see the “Video unavailable” message.

    Thread Starter karthickr

    (@karthickr)

    Thanks for your support.

    I have sent the dummy URL for your purpose. But on my page, I have used the valid URL.

    For eg:
    Video Type: YouTube
    Video Link: https://www.youtube.com/watch?v=w47PU9ppuF8

    Still, I got the same black screen on my window. How can I resolve this?

    Plugin Author plugins360

    (@plugins360)

    Kindly share me your site link in where we can check this issue directly.

    Plugin Author plugins360

    (@plugins360)

    If you have problem sharing your site link publicly, you can share it to us privately here.

    Thread Starter karthickr

    (@karthickr)

    We are not hosted our site in the public domain, we are working in localhost.

    Please check the below iframe code for your reference, while clicking the iframe src link, it’s permanently redirected to the player-embed page(like as shared black screen snap).

    <iframe width=”560″ height=”315″ src=”http://localhost:65457/player-embed/id/4547&#8243; frameborder=”0″ scrolling=”no” allow=”accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture” webkitallowfullscreen=”” mozallowfullscreen=”” allowfullscreen=””></iframe>

    Plugin Author plugins360

    (@plugins360)

    Actually, I would like to inspect the HTML source of this page URL http://localhost:65457/player-embed/id/4547 to find the exact reason for this issue.

    I believe this is a conflict. So, kindly try disabling your plugins one by one to find which causes this issue. If you’re able to identify the conflicting plugin, then please check if they have any setting that can cause such conflicts and disable it.

    If possible, kindly get me the HTML output generated in your browser for this URL http://localhost:65457/player-embed/id/4547. So, I can get a clue on this issue.

    Thread Starter karthickr

    (@karthickr)

    I have deactivated the plugin one by one and checked this issue on our page. But, still, the same black screen is shown on the page.

    If I use this shortcode in the description box as like below,
    [aiovg_video id=4547 youtube=”https://www.youtube.com/embed/w47PU9ppuF8″%5D

    Then, Video’s playing fine. Please find the below iframe src URL using the shortcode

    <iframe width=”560″ height=”315″ src=”http://localhost:65457/player-embed/id/4547?youtube=https%3A%2F%2Fwww.youtube.com%2Fembed%w47PU9ppuF8&#8243; frameborder=”0″ scrolling=”no” allow=”accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture” webkitallowfullscreen=”” mozallowfullscreen=”” allowfullscreen=””></iframe>

    It should be shown like this

    First one is the default black screen as I told already, then the second one, tried by using the shortcode in the description box.

    As you are asking the HTML code for this URL http://localhost:65457/player-embed/id/4547, but I clicked the URL in a new tab, it redirected permanently into the new URL as http://localhost:65457/player-embed and shown the black screen with the play icon.

    Plugin Author plugins360

    (@plugins360)

    Really strange. Please, try changing your theme. This is not a common issue. I did checked using a fresh WordPress installation now and YouTube videos are working fine for me here. So, it’s really hard to get you a fix without checking the issue page directly. It would better if you could add your site files in a development server and send us the link.

    Alternatively, go to our plugin’s general settings page and check “YouTube” in the “Use Native Controls” option. Let me know if this worked.

    Plugin Author plugins360

    (@plugins360)

    Since, we didn’t hear from you for a long time, we are closing this topic for now. But, you can re-open this later when you need.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Video not playing in detail page’ is closed to new replies.