Support » Plugin: All-in-One Video Gallery » Video Gallery widget

  • Resolved Dan Caragea

    (@dancaragea)


    Hi,
    I noticed that AIOVG Video Gallery widget is not properly displayed in Firefox (in right sidebar). First video does not appear (it is an empty space) and its duration appears after the title, on the right. Please, see this:

    Firefox – https://snipboard.io/zseYrd.jpg
    Google Chrome – https://snipboard.io/ec3xkN.jpg
    Opera – https://snipboard.io/LiFRoG.jpg – and same for IE.

    P.S. Please look after „Video (colecția…)”. All other widgets in sidebar (and not only) are displayed correctly.

    Please check. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor wpvideogallery

    (@wpvideogallery)

    Kindly try adding the following CSS code under the “Appearance => Customize => Additional CSS” menu from your WordPress Admin Dashboard,

    .aiovg.aiovg-videos-template-classic {
        clear: both;
    }

    Hope this solved your issue!

    Thread Starter Dan Caragea

    (@dancaragea)

    OK, thanks – that solved the issue for Firefox! But now, in Firefox Opera and IE too, all pages and posts (each page and post) displays the same videos in Video Gallery widget from sidebar (are same for selected pages) – and I chose RANDOM. In Google Chrome is OK (random).
    Please solve this, too.

    Plugin Contributor wpvideogallery

    (@wpvideogallery)

    Reason for the Issue:

    I guess you are using a caching plugin that caches the page output. So, each time you refresh the page, the same cached content is shown. This is the reason you always see the same videos.

    Proof the RANDOM option works with our plugin:

    Kindly reload the Home page by changing the number assigned to the “nocache” parameter in the URL.

    For example,

    https://dan-caragea.ro/?nocache=1
    https://dan-caragea.ro/?nocache=2
    https://dan-caragea.ro/?nocache=3

    You can see each time the page is loaded, a different set of videos are loaded in the widget. So, the RANDOM option works.

    Solution:

    I have no idea about the caching plugin you use. Kindly check if your caching plugin has an option to exclude the widget from caching. If it has, you simply need to exclude our widget from the caching and this should solve your issue.

    I see some caching plugins provide the option to exclude HTML elements that have a specific word. If your caching plugin provides such an option, you can simply exclude the keyword “aiovg”.

    Hope this solved your issue!

    Please correct me If I have misunderstood your question.

    Thread Starter Dan Caragea

    (@dancaragea)

    Thank you for the quick response!

    1. I use WP Super Cache plugin. I tryed to exclude keyword “aiovg” there (Rejected User Agents). But the issue was not solved.
    2. In Google Chrome everything is OK (Why? Same caching plugin). If I click on my Video page () several times, each time are displayed random videos, including in Video Gallery widget from sidebar.
    In Firefox Opera and IE browsers the same videos are always displayed whenever I click (just copyy the link and try in these browsers).
    3. I don’t understand, with same caching plugin and AIOVG different results in different browsers!

    P.S. I cleared cache on site and this browsers before.

    Plugin Contributor wpvideogallery

    (@wpvideogallery)

    I confirm the caching issue appears in my chrome browser too. I guess you had logged in to your website admin on your chrome browser. By default, the caching plugins disable caching for the admin user. So, you are not getting the issue there.

    Kindly submit a ticket here https://plugins360.com/support/

    So, I can get more details about your website privately and further investigate the issue.

    Thread Starter Dan Caragea

    (@dancaragea)

    Thank you, I submited a ticket.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.