Support » Plugin: WP-Stateless - Google Cloud Storage » Video Files 404 in Media Library

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Alim

    (@alimuzzamanalim)

    Hello @patopaiar,

    Please enable the File URL Replacement feature.
    In your post, local media URL is inserted because it takes little time to upload to GCS.
    When it’s get synced the local file gets deleted. So you can’t see the video.
    If you enable that feature it will replace the local URL to GCS URL on the fly.

    We will take a look.
    I have created a GitHub issue https://github.com/wpCloud/wp-stateless/issues/340

    patopaiar

    (@patopaiar)

    Hi Md. Alimuzzaman Alim

    Thank you for replying and for looking into this.

    File URL Replacement feature has been always enabled. This is why files that are not video files get the correct storage.googleapis link as shown in screenshot https://drive.google.com/file/d/1rVgW_zS9LB_OqHhPbGhyedogg0EypzHy/view?usp=sharing.

    These are our settings:

    https://drive.google.com/file/d/1PdFq9J0N2U3IcaAUKJ9ySFFqopf7A91J/view?usp=sharing

    And

    https://drive.google.com/file/d/1ulEXKieXmclWon84G5jLl8tdr4tUyTsC/view?usp=sharing

    In your post, local media URL is inserted because it takes little time to upload to GCS.

    This is not correct. I understand what you say but this is not the problem we are having. Even days after the upload, all files that are not video files are replaced with the googleapis url and video files are not.

    When it’s get synced the local file gets deleted. So you can’t see the video.
    If you enable that feature it will replace the local URL to GCS URL on the fly.

    This is not correct. This is not happening and this is exactly the problem we are having. When the file is jpg, or pdf, docx, png, anything really, the feature replaces the URL on the fly correctly. But for files that are video files specifically, the local URL is loaded instead of the GCS URL.

    If there is anything I can do to help debug the issue, please let me know, I am happy to help to solve this bug.

    • This reply was modified 8 months ago by  patopaiar.
    • This reply was modified 8 months ago by  patopaiar. Reason: clarifying the issue
    Plugin Author Alim

    (@alimuzzamanalim)

    Hi @patopaiar,

    Did you added extension for the video file in the Supported File Types field?

    That’s not suppose to happen, it must be conflict with other plugins.
    Can you please try to disable other plugin?

    The MP4 files are working fine on my tests.

    • This reply was modified 7 months, 3 weeks ago by  Alim.

    Are you kidding, man? You mean these, posted above: https://drive.google.com/file/d/1PdFq9J0N2U3IcaAUKJ9ySFFqopf7A91J/view

    I also commented in your issue https://github.com/wpCloud/wp-stateless/issues/340 with a fix I found which would be great if you could check into.

    Plugin Author Alim

    (@alimuzzamanalim)

    @patopaiar
    Sorry for that, made a response in GitHub issue.
    Thanks

    OK, no worries. Will follow up on Github.

    Plugin Contributor Anton Korotkoff

    (@anton-korotkoff)

    Closing due to inactivity.

    This is still not resolved. Github issue was not followed up on.

    I am having the same problem and I use the latest version of wp stateless. When I upload a video file through the frontend form, the video does not go directly to Google cloud storage instead it goes to local server. But if I upload an image file, it goes directly to Google cloud storage. Also if I upload a video through the backend media library it goes directly to Google cloud storage.
    Wp-stateless does not handle video upload through the frontend form. Please solve this issue in your next update.
    Also in your next update create an option under “synchronization” to “synchronize videos in the media library” and also create option in the media library to synchronize bulk of selected files.

    @dewlonse For the record, the problem you are describing is not the same one we were having. Our videos always went to GCS, it was just the URL which was not being replaced.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.