Support » Plugin: Featured Video Plus » Video embedding issue when using infinite scroll.

  • Hi Alex,

    As you requested, I’ve opened the forum topic for the issue that I have.

    Basically, in very simple terms, after theme’s infinite scroll loads more posts (I’m using Katla theme) the videos are not embedded anymore like they are in first posts prior to infinite scroll, they just appear as image thumbnails.

    I’m not a programmer nor IT specialist, therefore that’s the only way I can explain it.

    However, I had a chat with my mate who’s a coder and here’s what he asked me to ask you: “when I am doing ajax request to admin-ajax.php it looks like it doesn’t hook featured-video-plus plugin code and getting wrong html code with missing class names for featured-video-plus javascript.”

    Hopefully it makes sense and I would really appreciate your quick response as it has been a big hassle for me for nearly a week now..

    Thanks,
    Al

    https://wordpress.org/plugins/featured-video-plus/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Alex

    (@ahoereth)

    There are actually already quite some topics about problems with infinite scroll. I guess I am onto something to be released soon.

    For the time being: If you have programming knowledge you can make a call to the initFeaturedVideoPlus() JavaScript function whenever new posts appear on the site. At the moment the plugin simply does not know when new posts are loaded after the initial page load.

    Will keep you posted.

    Thank you very much for your reply.

    As I mentioned, unfortunately I only know the very basics of programming which is not sufficient enough to call the function as you mentioned..

    Could you briefly explain how and where to do this?

    Thanks again,
    Al

    Plugin Author Alex

    (@ahoereth)

    Should be fixed now. See 2.2.1 release. Tell me if it works 🙂

    Hi Alex,

    Thank you for a quick update.

    No, unfortunately the problem still persists…

    Plugin Author Alex

    (@ahoereth)

    Do you have a demo site (running your theme and my plugin) for me to check out? I do not have access to the theme’s source files and therefore cannot really look into it. I simply tried with other infinite scroll plugins.

    Hi Alex,

    Thanks for your reply.

    I’ve set up a demo site for you to have a look. It runs the same theme I’m using for my blog and I’ve obviously installed your plugin as well.

    You’ll notice, when you scroll down in the homepage, the next posts that are loaded by IS are image thumbnails..

    Thanks again, greatly appreciated,
    Al

    Plugin Author Alex

    (@ahoereth)

    Can you give it another shot with the 2.2.2 update?

    You’re a genius Alex!

    It does embed videos now, but there’s one slight issue with the sizing, it doesn’t set the size properly or some reason once more posts are loaded. I’m sure it’s only a minor thing to rectify.

    Demo site with updated plugin:

    Thanks once again, this is amazing,
    Al

    Alex, just to save you a bit of time, it works fine (sizing issue I mentioned above) when you replace frontend.js and frontend.min.js of version 2.2.2 to the ones of version 2.2.1. That might make your life easier when it comes to tracking down the issue.

    Also, as I promised, I made a donation just now. Once again, thank you very much for your help in sorting this issue out, you’re a legend.

    Thanks,
    Al

    Plugin Author Alex

    (@ahoereth)

    So is the linked demo site now using the 2.2.1 scripts? Because I cannot reproduce the described sizing problem.

    And thanks for the donation! Received it 🙂

    I’ve put the 2.2.2 scripts (frontend.js, frontend.min.js) back in, so you should now see the problem . Hope this helps you to trace the issue.

    My pleasure mate 🙂

    Levy

    (@andrelevy)

    I’ll +1 this issue. Here’s my site: http://andre.levy.x10.bz/misandria/

    The plugin works for the first batch of posts, but not for the new ones that come along.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Video embedding issue when using infinite scroll.’ is closed to new replies.