WordPress.org

Support

Support » How-To and Troubleshooting » Video Embed worked on Chrome / iOS. Not Firefox or IE

Video Embed worked on Chrome / iOS. Not Firefox or IE

  • The WordPress 3.6 Video embed feature seems to play videos on Chrome and iOS devices.

    But run it the same way through Firefox or Internet Explorer and it either black screens or has an eternal loading loop.

    Also, all browsers seem to be missing the control buttons as well.

    Here’s a link to one of the videos:
    http://cattrigger.com/yoplait-light-boston-cream-pie/

    The code for this is simply:
    [video src="http://cattrigger.com/portfolio/video/animation/work/yoplait/complex_yoplait_boston_small.mp4"]

    Is there a way to get this working on IE and Firefox? Also what of the disappearing control buttons? I would appreciate any help someone could give me.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    Works for me in FF.

    Have you tested it on a default theme?

    esmi

    @esmi

    Forum Moderator

    It’s working for me using 3.6.1, a video from wordpress.tv, the Twenty Thirteen theme and FF 23.

    Is the link I’ve posting working with you?

    How would the theme keep the video from working?

    esmi

    @esmi

    Forum Moderator

    If this is a video that you uploaded to your site, then you will need to use a video player plugin. Only the sites listed in Embeds can be automatically embedded into your Posts & Pages.

    Apparently this is a new feature from WordPress that allows you to embed videos, using mediaelement.js, supposedly to be compatible with everything:

    Audio / Video support in Core

    This is where I got it from. Again, seems to work perfectly for everything EXCEPT those two browsers.

    I have the exact same problem. The MediaElement plugin did Flash fallback in Firefox perfectly. The MediaElement integration in core, not at all… I get a “No video with supported format and MIME type found.” in Firefox since core started handling [video] shortcodes. Ack!

    Does MediaElement work on the newest WordPress? When I go to its website, it crosses itself off as compatible with with, now that it’s part of Core.

    I vaguely do remember my videos USED to work, thanks to the Flash fallback, but now it doesn’t and it’s frustrating.

    I removed the plugin since MediaElement is part of Core now.

    The Flash fallback in Firefox for playing mp4 videos, however, seems to have stopped working for some people, myself included.

    Did it happen after or before you started using Core?

    It happened to me before, and when I upgraded to 3.6.1 in hopes it’d fix it. No go.

    Since upgrading to 3.6, which is when it was integrated in Core I believe, or at least it was when the MediaElements plugin began conflicting with Core and so I removed the plugin.

    Not sure how to force Firefox to use Flash, any ideas are welcome. 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Video Embed worked on Chrome / iOS. Not Firefox or IE’ is closed to new replies.