WordPress.org

Support

Support » Plugins and Hacks » [Resolved] VFB conflict with WP UI

[Resolved] VFB conflict with WP UI

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Matthew Muro

    @mmuro

    This is not a VFB issue. All CSS and JS are loaded only on VFB pages.

    Contact the developer of WP UI.

    @MatthewMuro – I’m using your VFB Pro version (2.0.1), with the same WP (3.4.2) and WP_UI (0.8.5) versions as the OP and I have the identical problem.

    You indicate:

    All CSS and JS are loaded only on VFB pages.

    But in your file ‘visual-form-builder-pro.php’ starting at line 154, I see:

    // Add CSS to the front-end
    	add_action( 'wp_enqueue_scripts', array( &$this, 'css' ) );

    And (same file) at line 1085:

    /**
    	 * Add form CSS to wp_head
    	 *
    	 * @since 1.0
    	 */
    	public function css() {
    		wp_enqueue_style( 'visual-form-builder-css', apply_filters( 'visual-form-builder-css', plugins_url( 'visual-form-builder-pro/css/visual-form-builder.css' ) ) );
    		//wp_enqueue_style( 'vfb-date-picker-css', apply_filters( 'vfb-date-picker-css', plugins_url( 'visual-form-builder-pro/css/smoothness/jquery-ui-1.9.2.min.css' ) ) );
    		wp_enqueue_style( 'farbtastic' );
    		wp_enqueue_script( 'visual-form-builder-quicktags', plugins_url( 'visual-form-builder-pro/js/js_quicktags.js' ) );
    	}

    I may be missing something but afaik, this will cause these four files to be added wherever wp_head() is called (as your comment suggests.) That’s pretty much every page, the way I use WordPress.

    The css in jquery-ui-1.9.2.min.css seems to conflict with that used by WP_UI tabs, which is causing the OP’s issue. If I comment it out of the the css() function (as above), WP_UI works normally, but, of course, it breaks your date picker popup.

    Maybe you can suggest a work around. Thanks.

    Plugin Author Matthew Muro

    @mmuro

    Sigh…there’s a filter right there. Don’t comment that line out. vfb-date-picker-css.

    All you have to do is point to an older version of jQuery UI that is compatible with WP UI. Or, according to another user, change a setting in WP UI to use a “jQuery style” instead of a “CSS style.”

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] VFB conflict with WP UI’ is closed to new replies.