Support » Fixing WordPress » Vexing Image Upload issue

  • Im developing a site built on wordpress multi site. Much of the content is being developed and added by a group of remote interns. When they try to upload an image either to a post or directly to the media library they get an error ” Sorry you are not allowed to upload files” I have upgraded their roles to Admin to see if that solves the issue and it doesn’t. I’m able to upload files fine, and am at a loss as to what the issue might be.

    Could any one give me some trouble shooting guidance on this

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sounds like a plugin/theme conflict. But if the site has a lot of visitors/users along with a lot of plugins/themes, it might be difficult to troubleshoot that on a live site.

    My suggestion would be to first install this plugin:
    https://wordpress.org/plugins/health-check/

    That plugin is written by the WordPress community and some of it is actually in WordPress core now. And I believe it should be compatible with WordPress Multisite, but unfortunately I haven’t tested it with Multisite yet.

    What it allows you to do is to disable all plugins/themes and troubleshoot your issue without it affecting anyone else using/visiting the site.

    Only thing there is, you would want to create a new user with the same role as the interns and troubleshoot through that new user. Of course that new user will need to be able to activate/deactivate plugins. So that you can activate the “Health Check” plugin and use its troubleshooting options.

    Thanks Thomas Im aware of that plugin but wasnt thinking about that for this because – Ive increased one of the interns roles to – admin and she still has the issue even though I don’t. The site isn’t in production yet. So i’ll turn off plugins and see if it makes any difference to her

    Thanks again Thomas turns out it was plugin called Network Media Library

    Weird that it prevented some of us from uploading images and not others.

    Best

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.