WordPress.org

Support

Support » How-To and Troubleshooting » Very Unique Question (database related)

Very Unique Question (database related)

  • Didn’t even bother looking for an answer to this because I wouldn’t even know where to begin. I installed the latest wordpress with the k2 theme. i’m a perfectionist kinda (yea i know i’m silly), so i simply had to have my post id’s go in order. my page ids (starting with the about page) start at 2, 3, 4 … 7. and my post ids start from 8,9 … 15. i of course realize it’s a big nono editing the database tables; however i have quite a bit of experience in database work, so i thought no big deal. i editing the post_ids and correctly changed the auto increment values, and everything displays correctly (in order) except for one thing that irks me. onto my problem …

    you know how if you update a post, create a page, etc, a little banner pops up and says “XXX done successfully” above the editing window? Mine does not do that now, and for the life me, i can’t figure out why. i’ve looked through the PHP-admin code, and i cant seem to find anything useful (not really familiar with PHP).

    ANY help would be greatly appreciated, as this is a weird problem. it may not seem important, but its one of those things that is making me pull my hair out 🙂

    thanks

    note: for clarity, i did the same procedure with categories (making them in order), and if i update a category, the update banner appears there. if this issue is database related, the ONLY thing i could think of would be the meta_id field in the wp_postmeta table, as i didn’t change any of those values when i updated the post ids

Viewing 1 replies (of 1 total)
  • Just for the record: post and Page IDs go together, so if after 5 existing posts you create your first Page, it will have an ID of 6.
    I’d suggest start it over – I mean the whole blog (and forget the OCD 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘Very Unique Question (database related)’ is closed to new replies.