Support » Plugin: Restrict Usernames Emails Characters » Very strange – working but not working

  • Resolved JJNW

    (@jjnw)


    Hello.

    I have a live website and your plugin isn’t working – but when use it on my localhost (direct transfer, nothing different what-so-ever, promise), and it works.

    Odd, it works perfect on localhost, but on live server (idential website) it doens’t.

    Any, any suggestions? Its a great plugin…on localhost test server, but not happening on live website.

    Please.

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I noticed only the last entry of each list, Not allow these names and Restriction by part (contain,doesn’t contain,starts with,ends with) works on the live website. Very strange. Can’t figure it out yet.

    So far, everything else is working as expected on localhost.

    On live website, everything is working as expected, except “Restriction by part (contain,doesn’t contain,starts with,ends with)” and not working with “Not allow these names” – only the last entry of these list are respecting the rules. Still trying…

    ANY help would be sincerely appreciated.

    Thank you.

    I checked all logs, no issues.

    I checked file permissions on live server, and user/group, and not an issue.

    Still trying, but running out of ideas.

    Please help, if you could.

    Thank you.

    Okay, so on localhost everything works great. On live site everything works, except checking names and partial names. Only the last entries on these lists are respected.

    Any suggestions, please. I’m out of ideas ;(

    Thank you.

    Trying to still figure it out…

    I notieced that the “Text Direction” button doesn’t function on live server, works on localhost, but not live server.

    Any help would be sincerely appreciated.

    Thank you.

    Okay, everything is working now – but the original problem still remains a problem.

    Last entry of each list, “Not allow these names” and “Restriction by part” works on the localhost website, but not live website.

    Still can’t figure it out 🙁

    Still trying to figure it out. My mind has melted. Trying EVERYTHING and nothing is making sense why it works perfectly on localhost, but not on live server 🙁

    Anyone has a suggestion, please advise, I would sincerely appreciate it 110%.

    Thank you.

    Plugin Author Benaceur

    (@benaceur)

    Thanks …
    I will check, give me some time.

    • This reply was modified 5 months, 2 weeks ago by Benaceur.
    • This reply was modified 5 months, 2 weeks ago by Benaceur.

    Please. I wait on pins and needles.

    THANK YOU!

    Plugin Author Benaceur

    (@benaceur)

    Edit this file: wp-content\plugins\restrict-usernames-emails-characters\classes\classe_val.php
    and replace line 16:
    $names_partial = array_filter(explode(PHP_EOL, $names_limit_partial));
    by:
    $names_partial = array_map('trim', explode(PHP_EOL, $names_limit_partial));
    and replace line 156:
    $names = array_filter(explode(PHP_EOL, $names_limit));
    by:
    $names = array_map('trim', explode(PHP_EOL, $names_limit));

    Okay, will give it a go and report back to you in several minutes, promise.

    THANK YOU!

    JJ

    EXCELLENT FIX!

    Yes, it’s now working on localhost an dlive server – did a lot of testing, no errors, no php errors in log, works exactly as expected.

    THANK YOU! Review coming up!

    JJ

    Plugin Author Benaceur

    (@benaceur)

    I will make the changes in the next update.
    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.