Support » Fixing WordPress » Very strange encoding problem

  • midori

    (@midori)


    Although the general coding is right (é and others displaying in the menu, title, …), the texts of the posts do not display any special character. It is under iso-8859-1, yet. If I turn to Utf-8, it is worse.
    Not that it displays something strange instead: it displays nothing… like: “Voil, malgr tout,” instead of “Voilà, malgré tout,”. But the letters ARE in the database, I double checked that.
    So it is a matter of how posts are fetched – displayed, but I can not seem to pinpoint were it happens, and, even stranger, it happens in my online blog, but not on my developpement server O_o
    Any idea ??

Viewing 6 replies - 1 through 6 (of 6 total)
  • Mark (podz)

    (@podz)

    Support Maven

    This may be worth a try.
    Add this to your .htaccess file:
    AddDefaultCharset utf-8
    or
    AddDefaultCharset iso-8859-1
    Choose the one that matches your chosen wp encoding.

    midori

    (@midori)

    Done, already, does not change anything. If you look carefully, it is just like the post + comments output where going through a function that suppresses all accentued + ç + … characters. In my selfmade *last comments* function, it does not…
    But, thank you for trying 🙂

    midori

    (@midori)

    Ho O_o I deactiveted some plugins I did not absolutely need, before I activated grins, and suddenly: it works o_O

    Jack

    (@moxie)

    Doesn’t work for me. I have a similar problem. Only one plugin activated (wppaginate), automatic xhtml-correction off, .htaccess-file yes or no, but still my posts that were written in UTF-8 show up terrible, éven when using UTF-8 through Firefox.
    Everything is OK again when turning to iso-8859-1, but the posts were NOT written that way I’m sure… 🙁

    Jack

    (@moxie)

    I will go and try to disable the plugin soon, but what do you mean with that the database also has a default coding? Where in the database can I find this? Because in the optionstable in the database, the value follows the value/method I choose from the optionsmenu in the administrationarea.

    midori

    (@midori)

    Well, if you do use a tool like PHPMyadmin to access your DB (as I do, I have much more than only my blog on it), I noticed that already twice it caused problems of encoding…. so…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Very strange encoding problem’ is closed to new replies.