WordPress.org

Forums

NextGEN Gallery
Very slow site due to plugin :-( (3 posts)

  1. twilitegxa
    Member
    Posted 1 year ago #

    If I disable this plugin, my site loads within 3 seconds, but with it enabled, it takes a whopping 10 seconds or more to load. How can I speed things up? It's also causing a CPUY overage on our server, so we absolutely need a solution for this. You can check out site at modelmachine.com

    http://wordpress.org/plugins/nextgen-gallery/

  2. jtintner
    Member
    Posted 1 year ago #

    I did a site speed test and noticed that a few of your CSS files are taking a while to load. BUT it loaded just fine for me, is the next-gen plugin activated right now or have you de-activated it?

    3.8 seconds to load the site.
    Here is the speed test

    Have you looked into a cache plugin? Hyper cache does a pretty good job of speed up websites that I have experienced slow speeds before.

    Also, look in your hosting provider. Sometimes if you are on a shared hosting plan it doesn't matter what it is you are doing it could be someone else that is chewing up bandwith. See if your being throttled if you have cpanel you should be able to see CPU throttling somewhere in there that will give you a good idea if it's more than just the plugin

  3. twilitegxa
    Member
    Posted 1 year ago #

    I have WP Super Cache enabled and configured according to HostGator's recommended specifications (we're hosting on HostGator). We have a reseller account, so the CPU usage is not actually accessible through the cpanel, but yes, we're on a shared hosting plan.

    When it loaded within 3 seconds on pingdom, it was when the NextGen Gallery was deactivated, so when I enable it, which is what is the case right now, it loads a lot slower. According to HostGator, NextGen Gallery is what seems to be causing the CPU overage, because when they send the report of why it's getting temporarily blocked, all the pages that are experiencing the issues during the time of the report being generated are using NextGen Gallery and the URLs point to them galleries int he links they provide as well.

    Do you happen to know if we upgrade to the premium version if this would help? Could it be some issue with having too many galleries and using the free version? We do have quite a bit of galleries, as it's a modeling agency website.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.