• We’ve been experiencing extremely slow response when trying to access the users.php page on our production website (https://www.clarku.edu). It takes close to a minute to load, and occasionally times out.

    Working with our hosting provider, we were able to identify the problem using New Relic. The two items that consume the most time are WordFence calls:

    #WordfenceLS\Controller_Users::can_activate_2fa
    36.8 seconds
    
    #WordfenceLS\Controller_Users::_user_can_for_blog
    21 seconds
    

    Is there a setting we can change to fix this?

    Thanks in advance,

    Mark Pemburn
    Web Application Administrator
    Clark University

    • This topic was modified 1 year, 4 months ago by mpemburn.
    • This topic was modified 1 year, 4 months ago by mpemburn.
    • This topic was modified 1 year, 4 months ago by mpemburn.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @mpemburn, thanks for reaching out to us.

    It’s certainly not regular behavior for these calls to be delayed so heavily when loading any page on your site where Wordfence may add content. I think it’d be appropriate in this instance to request a diagnostic report so that I can see whether anything in your configuration or installed plugins may be contributing to the increased load times.

    You can send the diagnostic report to wftest @ wordfence . com. The link to do so appears at the top of the Wordfence > Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    NOTE: It should look as follows – Screenshot of Tools > Diagnostic > Send by Email

    Thanks,
    Peter.

    Thread Starter mpemburn

    (@mpemburn)

    Thanks Peter–I just sent the report.

    After creating this ticket yesterday, I passed it along to our web host support team, since we work closely on our WordPress issues. They saw your reply and said, “It’s also worth mentioning that you have a relatively high number of blogs (300+) and a high number of users (600+) so it might simply not be feasible to call the can_activate_2fa and _user_can_for_blog for each user/blog and they may instead need to add an array version of the checks which would perform the capability check for many users at once, reducing the number of individual calls.”

    –Mark

    Thread Starter mpemburn

    (@mpemburn)

    Hi,

    Are we close to having a solution to this issue? We are still experiencing extremely long load times.

    Regards,

    Mark

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Very slow response on users.php due to WordFence’ is closed to new replies.