Support » Plugin: Autoptimize » Very slow response and then page error for some javascript files: Example bellow

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    In that case exclude it from JS optimization and all will be well? 🙂

    Unfortunately, I have exclude this file in the AutoOptimize settings, but it will not be disabled.
    Only when I delete this file from the original simplepress plugins source will the problem be fixed!

    My exclude settings were tested as follows and did not work

    printThis.js, js/jquery/jquery.js
    or
    wp-content/plugins/simplepress/forum/resources/jscript/print-this/printThis.min.js, js/jquery/jquery.js
    or
    wp-content/plugins/simplepress/forum/resources/jscript/*.js
    and other sample

    I even notified the developer of the sp plugin, but my topic removed by sp team!!

    This file is called in the Simple Press plugin as follows:

    # load the print this script for topics
    $script = (defined(‘SP_SCRIPTS_DEBUG’) && SP_SCRIPTS_DEBUG) ? SFJSCRIPT.’print-this/printThis-dev.js’ : SFJSCRIPT.’print-this/printThis.js’;
    sp_plugin_enqueue_script(‘sfprintthis’, $script, array(‘jquery’), false, $footer);

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    the weird thing; when you exclude that file (but don’t use * in exclusions, that does not work), AO just leaves that file be.

    * when AO is not active it does not break?
    * what’s happens when “optimize JS” is off?

    When js optimization is off (uncheked), everything is fine.
    My problem is I can’t exclude this js file: (printThis.min.js)
    I have tried other files and they all excluded in AO, But this file cannot be excluded, So I face a slowdown and error on the page.
    You can install simplepress plugin and see what happens on the simplepress forum page with AO js Compression enabled
    I really don’t know what the problem is. The problem is with the AO or the Simplepress plugin??

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    When js optimization is off (uncheked), everything is fine.

    And when JS optimization is on but JS aggregate is off?

    But this file cannot be excluded

    that’s bizarre.

    So I face a slowdown and error on the page.

    So what error do you see/ get and where do you get that (on the page, on the browser console)?

    You can install simplepress plugin and see what happens on the simplepress forum page with AO js Compression enabled

    Afraid I don’t have time to install & configure a plugin which I know nothing about Shahriyar. Do you have a staging site where you could leave things broken for a while for me to look into this problem?

    I tried both js aggregate and the problem is same.

    that’s bizarre.

    I am also surprised. Because your plugin even excluded regular static js or css files, but this file….

    Of course not the problem with your plugin. The problem is the awful coding of the SP plugin, Because reviewing the plugin’s source, I found that the styles and script is not called in the standard way! But on the other hand, AO plugin will compress any file even if it’s not called as standard! and Also excluded

    I am designing a site at localhosts(wamp) otherwise I would show you the problem.

    simplepress is wordpress plugin and can find in wordpress.org

    I’m also a web developer and have only a little trouble with the English language and apologize if the sentences aren’t spoken well.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I am designing a site at localhosts(wamp) otherwise I would show you the problem.

    OK, so can you copy the HTML of a page where the problem occurs and of the autoptimized JS-file(s) into some pastebins or in a github gist?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    ah, also; what error do you see/ get and where do you get that (on the page, on the browser console)?

    error does not occur like a PHP error on the page. Server response takes a long time. or browser kill page

    I installed the site live for you to check.

    check this live url

    main page
    http://test.chabokgroup.com/aotest

    Troubled page: sp plugin
    http://test.chabokgroup.com/aotest/forum/

    if you need a admin username and password? I can email it to you

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, what currently is in the JS exclusions?

    wp-includes/js/dist/, wp-includes/js/tinymce/, js/jquery/jquery.js, sp-common.js,sp-forum-events.js,printThis.js,tooltip.min.js

    need a admin username and password?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Sharing login information is forbidden on these forums I’m afraid Shahriyar.

    Can you change the JS exclusion into

    
    wp-includes/js/dist/, wp-includes/js/tinymce/, js/jquery/jquery.js, plugins/simple-press/, tooltip.min.js

    Sorry for responding late.

    I changed exclusionÙˆ But again I couldn’t prevent the problem. also I tried different methods for exclusion but it didn’t work.

    I think we took too much time for this problem and thank you for your answers. so I’m using another forum plugin because this forum(simplepress plugin) apparently doesn’t have a future and does not seem to be properly programmed.

    I’ve used your plugin(AO) on various sites and it’s great.
    thank you

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    You’re welcome Shahriyar, feel free to leave a review of the plugin and support here!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.