WordPress.org

Support

Support » How-To and Troubleshooting » Very slow publishing

Very slow publishing

  • The 1.2 RC is very slow to publish. Sometimes the 1.02 version would be slow, but the 1.2 RC is consistently very slow. Concerned about the speed, in fact.
    There’s no feedback about what’s happening in the background to the screen, to understand what could be causing a slowdown.

Viewing 5 replies - 1 through 5 (of 5 total)
  • It’s the option to search a post for pingbacks that’s taking the time. Lot’s of time.
    No biggie, just turn it off. Auto pinging isn’t a good idea, anyway.
    Live and learn.

    I don’t think auto pinging even functions yet. I know the developers are aware that it doesn’t….hopefully once that’s fixed things will speed up…..or slow for functioning pings. 🙂

    In my experience it the slowdown is particularly bad on sites that don’t accept the pings like Cnet or Wired which you might be referencing in a post… Perhaps we could maintain a list of sites not to ping to override the default behaviour. I like to pingback/trackback on posts I make, but find I forgot too often to turn it off on some which then give the long post time…

    The desired behavior is to background the pings so that the poster gets immediate response that the post was inserted into the database. The developers are aware of this, though I’m unsure what the status of this is.

    I went to options, writing and looked in the update services section and removed http://rpc.pingomatic.com, and publishing was much faster I read about update services at http://www.wiki.wordpress.org/UpdateServices and decided to put http://rpc.weblogs.com/rpc2 in its place. For what I am doing I find it unneccessary to update at 14 different update services using pingomatic..

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Very slow publishing’ is closed to new replies.