Support » Plugin: Instant Articles for WP » Very slow performance

  • Resolved lisota

    (@lisota)


    Not sure what is causing this, but RSS feed generation is VERY slow with this plugin. I see that you reduced the post count to 10 from 100.

    We are on dedicated hardware, not a shared host, so our site performs significantly faster than most.

    With 100 items in the instant articles feed, the feed takes 1.2 minutes to render. Compare this to our regular feed of 35 articles, which generates in ~1 second.

    Without further digging in to the code, I can’t help but think there is some queries that need to be optimized or rewritten.

    https://wordpress.org/plugins/fb-instant-articles/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author diegoquinteiro

    (@diegoquinteiro)

    lisota, this is not related to the query. We do a very CPU-intensive transformation of the markup of each article in 2-pass (first parsing it to a DOM tree and then iterating node by node applying several transformation rules to create an in-memory representation).

    There is definitely room for improvement, and we aim to drop the time substantially, but I’d recommend not using the RSS: it was kept in the plugin mostly to ensure backwards compatibility.

    You can, instead, connect to your page using the Settings page and then your posts will be pushed to Instant Articles automatically on save, using our API, and one-by-one.

    Does that help?

    That does help. This is actually quite confusing. Between the plugin admin screens and the FB admin pages that have a spot for the RSS feed, I assumed that the plugin required some hybrid of RSS feed and API, but it isn’t clear when each of them get used.

    In fact, it wasn’t clear to me at all that there was auto-publishing going on via the API until I looked at the article list in the Pages app, which is wildly different than the article list that appears in the RSS feed. Custom post types aren’t appearing in the RSS, but are appearing in Pages.

    @lisota, I’ve taken note of your feedback — it’s much appreciated!

    Also, regarding the performance, the latest release (v2.9 as of now), contains some significant improvements to performance. Could you give that a try and see if your experience is better?

    I’m marking this as “resolved” for now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Very slow performance’ is closed to new replies.