Support » Plugin: SiteGround Security » Very slow log in / out.

  • Resolved Sean

    (@sean-h)


    Hi there,

    I thought to replace Wordfence free with SG Security on the site in question. The idea is to use it on all my sites, if I can first learn how it works šŸ™‚

    It’s all installed and no crashes, and navigating the admin dashboard is as fast as usual, but logging in and out is painfully slow. I should add that I had WF 2FA together with Google reCaptcha v3 on the log in page, and while I did check the 2 boxes in WF settings to remove all database tables on deactivation, I have a feeling something got left behind, somewhere, but I have no idea where. If I deactivate SG Security, log in / out is then lightning fast. However, if SG Security is active and I log in via ManageWP, log in is light speed, but log out takes forever.

    Any ideas what could be causing a very slow log in/out?

    I do not have SG security nor WF on the staging copy of the same site and it is logging in and out fast. My other sites still with WF log in and out just fine.

    • This topic was modified 1 month, 2 weeks ago by Sean.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter Sean

    (@sean-h)

    Update:

    Changing internet connections seems to have solved the problem. But my question is why?

    I had similar problems about a year ago when I was using this same fibre provider in Spain, Cloud WiFi. At home in Belgium, or any other ISP, no such problems.

    Also, loading the site in question now on another browser not logged into WP takes a while, unless I use my mobile hotspot.

    Last time, it turns out Wordfence did not like the way my ISP was verifying/presenting the IP I was coming from, or something to that effect. I had manually added some IP’s in the WF block list. It was only when I removed all custom blocked IP’s did that site load fast, logged in or out.

    So now when I use a mobile hotspot from my phone, in other words, another IP, no log in or speed problems with SG Security.

    I am experiencing the same issue and I believe it’s not your internet connection. And for me, I feel that, ever since I installed SG security, the website is slower.

    Thread Starter Sean

    (@sean-h)

    @idenovasi, I’m not jumping to conclusions just yet. Like I say, when I switch to another connection, the sites log in and out nice and fast. The irony is the connection giving the problems is an 80mbps uncapped fibre optic line, and the one that works fine is my 4G mobile hotspot. The only reason I can’t just keep using the mobile hotspot is it is pre-paid, so not particularly cheap. My monthly budget for mobile internet is ā‚¬5. I prefer to spend the money saved on things like snowboard gear. There are enough free wifi hotspots all over Europe.

    Anyhow, I have now installed SG Security on 2 of my 8 sites, the second one has exactly the same problem, except when I switch ISP connections.

    Plugin Author Elena Chavdarova

    (@elenachavdarova)

    Hello @sean-h,

    I am sorry to hear you are facing such issues.

    In order to isolate the issue I would like to ask you a couple of questions:

    1. Is the slow login/logout issue only present if you are using ManageWP to login into your websites? Could you please try login via SiteGround SiteTools WordPress tool, or directly from the login page and update us with the results.

    2. Additionally please perform the above mentioned test with all browser cache and cookies deleted.

    We are looking forward hearing from you.

    Best Regards,
    Elena

    Thread Starter Sean

    (@sean-h)

    Hi @elenachavdarova,

    1. No, the slow log in/out is when using the regular log in page, and Site Tools. Logging in from ManageWP is fine.

    2. All cache and cookies cleared, both server and browser. Yes, I even tried another browser (Chrome) My primary browser is Safari on an M1 MacBook running Big Sur, if that is useful info.

    All problems go away if I either switch to my mobile hot spot, or disable SG Security. So, it would seem SG security does not like something about my current fibre ISP. The other thing is, I have to wonder if site visitors would have the same problems, because the sites also seem slow to load when not logged in.

    As it is now, I only have SG Security installed on 2 live sites, and both sites experience the exact same problems with SG security on my current ISP, but no problems with Wordfence.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I am afraid there is no way we can test with every possible plugin and theme combination out there. Our plugin does not slow down the login process. If something else is misbehaving and doing so, please provide us with logs, exact instructions on how to recreate it, error messages, etc. I am afraid that with the information provided there is nothing much we can do about it. It could be even your mobile internet being faster or slower than the other one for example.

    Thread Starter Sean

    (@sean-h)

    Don’t worry, I fully appreciate that plugin/theme authors, hosts etc simply cannot test every use combination, that is why there are beta programs, and even then, something will inevitably be missed. I do my utmost best to take as much as possible into account.

    No, this plugin does not normally slow down the log in process, but in this extremely rare case it appears that it does. I say rare, because I can’t find any other reports that it does. Yes, I do my research, aka gooogling.

    Weirdly enough, there are sometimes 4 of us all streaming Netflix at the same time with no problems, so I do not think there is a speed issue with this fibre line.

    I had similar problems on this same connection last year. So I did some more ‘digging’, nothing has changed, same results. (I still have the dig results from last year, but I had to look for them, I’m terrible at filing stuff properly)

    What do you make of this? (this is the IP of my current connection. I also digged my IP at home from where I’m sitting, no errors whatsoever)

    dig -x 185.130.147.204
    
    ; <<>> DiG 9.10.6 <<>> -x 185.130.147.204
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 25907
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 512
    ;; QUESTION SECTION:
    ;204.147.130.185.in-addr.arpa.	IN	PTR
    
    ;; Query time: 39 msec
    ;; SERVER: 8.8.4.4#53(8.8.4.4)
    ;; WHEN: Tue Oct 19 10:41:52 CEST 2021
    ;; MSG SIZE  rcvd: 57

    add +trace after dig and you get this right at the end: connection timed out; no servers could be reached

    So, unless you feel like physically coming to Spain and testing on this connection, no, I don’t think there is much else we can do about this. I’m also not about to even try contacting this ISP because this account is not in my name, and I don’t speak Spanish. I’ll be home in Belgium next week and will try again there and see what happens.

    I think we can consider this topic ‘resolved’, because it looks like the problem is not with SG Security, but with my current ISP. However, I’m still very curious as to why I have this problem only with sites that have SG Security.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.