Support » Plugin: GatherContent Plugin » Very Promising, but Needs a lot of Work

  • I attempted to use this to import 700+ WooCommerce products, which was a big mistake. It became very labor intensive as the plugin doesn’t handle mass amounts of products like this very well, and there are some key pieces that just don’t even work.

    They’ve promised a new version for a while now.. so I’ll keep checking back to see if the issues have been resolved, as there is a lot of great potential with this plugin, but the execution is currently lacking.

    I’m a big fan of what this could be!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Justin Sternberg

    (@jtsternberg)

    Hey, just a heads up, we’re currently working on a complete rewrite of the plugin, and several issues should be fixed out of the box, as well as offering extendibility for additional features. I’m happy to see you’re willing to continue checking back. Watch this space!

    Plugin Author Justin Sternberg

    (@jtsternberg)

    We have released a massive update to the plugin and would love if you could check it out. If you find that you’re happy with it, we would also love if you would be willing to revise your review. Please let us know if there is anything we can do to help!

    Thread Starter invisiblue

    (@jayharle)

    Sounds good. My team will be testing this again soon! I do have high hopes for this, and would love to leave a nice review. I’ll confirm soon.

    Thread Starter invisiblue

    (@jayharle)

    Just tested the latest plugin version, and the import still hangs at 1% on a site that has Basic Authentication username/password applied to it.

    I also just tested it on a local WordPress installation, and am only seeing errors: http://imgur.com/a/3RMoB

    Plugin Author Justin Sternberg

    (@jtsternberg)

    We just released a few significant updates, one that should address the 1% issue with Basic Auth, and another that should make large imports more reliable. Please update and let us know how it works.

    As for your local, a few pieces I would like to know is what version of PHP you are using, and what your memory limit is set to? I’ve never seen that “well-formed” error before or had anyone else report it, so would definitely like to see what is going on there.

    Thread Starter invisiblue

    (@jayharle)

    I finally got back to testing the latest version of the import. I’m testing on a completely new site, with a fresh install of the Gather Content plugin.

    I have my api key entered and everything connects fine to our company Gather Content account. I’m able to select a project, and specific pages within the project to import.

    I’ve attempted to import a single page, and the import is getting stuck on 25%. I also attempted to import 2 pages at the same time, and it gets stuck on 13%.

    In each case.. with either 25% for 1 page, or 13% with trying to import 2 pages, those values are the first incremental percentage amount that shows up.. so this feels pretty similar to the old issue where it would hang at 1%. So it seems like it hangs right away like it did before. This site I’m testing on is also behind username/password Basic Auth.

    Still would LOVE to be able to use this. I have a team of 10 people and over 70 projects.. we use Gather Content A LOT, and copy/pasting by hand is a drag, man. 🙂

    Plugin Author Justin Sternberg

    (@jtsternberg)

    Thanks for getting back to us!

    If you’re behind Basic Auth, please follow the instructions (Working with password protected websites) at the bottom of this page: http://help.gathercontent.com/importing-and-exporting-content/wordpress-integration/wordpress-integration-configuration

    Hopefully once you get that properly configured, things should work as expected.

    Thread Starter invisiblue

    (@jayharle)

    Thanks for the quick reply, Justin!

    I think the problem is that I’m not seeing where this screen is that allows me to enter the Basic Auth creds: http://imgur.com/a/3WtBo

    Thread Starter invisiblue

    (@jayharle)

    FYI, here are screenshots of every page that I am seeing in the current version of the plugin: https://drive.google.com/open?id=0B-U_VUoIKi39NUVFcmVsZW5qdTA

    Thread Starter invisiblue

    (@jayharle)

    And as a sidenote.. on my local, the plugin looks like this, on a fresh WordPress install:

    View post on imgur.com

    The “Support” page looks the same.

    I have only one active plugin, GatherContent. The active theme is Twenty Seventeen.

    • This reply was modified 4 years, 6 months ago by invisiblue.
    Plugin Author Justin Sternberg

    (@jtsternberg)

    Hmm let’s see if we can figure out what’s going on (with both). For the local setup, can you enable WP_DEBUG and WP_DEBUG_LOG and reload and let me know if/what shows up in wp-content/debug.log? https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_DISPLAY

    For the other, it would be good to reach out to GatherContent support, and include the output of the Support information (and mention my name). We don’t want you to share that information in a public forum.

    And one other thing, if you’re able to edit your theme’s functions.php file, can you add this snippet temporarily and provide me the output?

    if ( is_admin() ) {
    	wp_die( '<xmp>'. __LINE__ .') $_SERVER: '. print_r( $_SERVER, true ) .'</xmp>' );
    }

    (it will show in /wp-admin.. obviously you will need to remove to regain the admin functionality)

    Thread Starter invisiblue

    (@jayharle)

    Just a quick update.. we were able to disable Basic Auth for the site in question and the import works!

    I will follow up again after I’ve been able to go through your instructions above.

    Thanks for you quick response again!

    I’m having the same issues. I can’t find a setting option (or link) to enter user/pass info, or know how to disable Basic Auth to get around this issue.

    My hope is this helps import and export as I can’t do either now and it’s very frustrating. Just using API credentials seems to do nothing.

    Plugin Author Justin Sternberg

    (@jtsternberg)

    Kevin, do you know that you do in fact have Basic Auth enabled? Does the browser (not the website) open a login dialog when you visit?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Very Promising, but Needs a lot of Work’ is closed to new replies.