Support » Fixing WordPress » Very long post is saved, but preview/published article is blank

  • Hello, good people,

    I wrote quite a long blogpost these past few weeks (not a new thing for me), but this one has an issue: on a certain size, it just gives a blank post once viewed online (the rest of the design is displayed).

    The post is 5058 words long (according to WP’s counter), and contains a few uses of videos and mp3s through direct Flash HTML code and plugins.

    On my blog, the preview always displayed well, until this week-end when I added more text. It began giving me a blank post: the post is saved in the DB, but the preview only gives the title and the timestamp, along with the rest of the design – nothing in the HTML source code, it’s as if the the_post() function wasn’t called. No error message in WP or from the host.

    I then made a few cuts and size tests: on my blog, the preview is fine when the counter is at 4850 words, and it’s blank when I add just one word.

    My blog is hosted at 1&1. I have published a far longer post a few months ago (mid-2008, WP 2.6) without issues, but 1&1 might have “upgraded” their servers in the meantime, I don’t know.

    I tried on another blog of mine on the same 1&1 account, and it would also fail, albeit at a different counter mark.
    Tested on another one of mine hosted at DreamHost, same result, different mark. Tried on other blogs, one at Atmaniak (excellent servers) or even my work blog (excellent server, hosted by, same same but different.

    On my own blog, I tried by disabling all plugins, but it didn’t make any change to the preview (or even published post).

    I tried the mod_security.c stuffs explained here:
    and also this one:
    but to no avail.

    Tried to change the memory limit using .htaccess and “php_value memory_limit 32M”, but it just brought a 500 error on 1&1 – and anyway I read somewhere 1&1 wouldn’t allow anything more than 20M.
    I’m planning to switch it all to DreamHost eventually anyway, but even on DH it fails…

    The curious thing is that I’m not adding anything more than simple text in the editor.

    I’m a bit at loss for suggestions. Anyone cares to tell me his thoughts? Thanks a lot…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Update:
    – I tested it on yet another host (, with WP 2.7.1: same result;
    – a friend of mine tested it on 2.3.1 blog on 1&1, and according to him it worked;
    – it doesn’t matter which part of the text is deleted to allow short size: start, finish, center, if I remove enough it works.

    Hence, it sounds like it would be tied to this issue:
    …which is apparently fixed in 2.8-bleeding, but I tried copy/pasting my post into this trunk public demo blog:
    …and it didn’t work still.

    Still digging…

    I temporarily fixed it.

    Fixed, because seeing that ticket 8533 blames wpautop, I tried installing the Jeff Minard’s Text Control plugin, which lets me choose which formatting option to use on a per-post basis. By default, the formatting uses “wpautop”, but thanks to Text Control, I was able to set it to the simpler “nl2br”. Worked like a charm! 🙂

    Temporarily, because I was forced to go through the HTML code in order for the post to look good (misaligned image-text combo, twice-too-huge lists, etc.). I can’t use the visual editor on this post anymore because it would break my well-placed nl’s…

    I truly hope this gets properly fixed in 2.8, so that I can 1) edit this post in Visual mode if I want to, and 2) remove the reliance on Text Control, which is handy but should not be used in such a cause.

    Please hear me, core devs!

    I have the same problem with a long page. Too bad Minard’s Text Control plugin doesn’t do pages…

    I’ll have to figure a way to make it go myself.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Very long post is saved, but preview/published article is blank’ is closed to new replies.