Support » Plugin: Extensions for Leaflet Map » Very interesting plugin

  • Hi First, I want to say how much I appreciate this plugin. I have been struggling for a while using both WP-GPX-Maps and Leaflet Maps. The first one provided altitude profiles and the latter did not. So I displayed 2 maps on my articles. (Not ideal of course). Seeing that this plugin can eliminate the duplication, I will remove WP-GP-Maps from the site.

    Some other things I noticed.
    – my site was using D3.js Version 3. Cursor tracking on a combined map and alti-profile display does not work with D3 V3. Upgrading to V6 fixes this.
    – Even with D3 V6 I am not able to make changes in the thickness of the polyline on the map nor activate several options such as the download option, the slope option etc.

    I have deactivated and removed WP-GPX-Maps from the site, activated the migration option, but not yet removed all the sgpx meta tags from the articles.

    I wonder if you have any suggestions about these issues.

    Regards

    The page I need help with: [log in to see the link]

Viewing 3 replies - 16 through 18 (of 18 total)
  • Plugin Author hupe13

    (@hupe13)

    Okay, this is really not for the forum. Another suggestion would be to put the code for Database Generated Pages in a plugin and only load the scripts and css when they are needed, i.e. the WordPress way with wp_enqueue_script and wp_enqueue_style.

    multiple hoverable tracks

    This is fixed in the next version.

    • This reply was modified 6 months, 2 weeks ago by hupe13.
    Thread Starter jackaspades

    (@jackaspades)

    OK I’ll try your enqueue suggestion. If you want private discussion/info about IGN documentation, you can contact me on jackahearts at e dot email

    Thread Starter jackaspades

    (@jackaspades)

    Update 1 : The GPPluginLeaflet.js library from IGN requires a data attribute when loading the script. (attribute is a json file which provides api key and access rights to the maps). So far unable to see how to load the data attribute using enqueue. All other libraries load OK with enqueue in the plugin.

    Update 2 : IF load latest D3 – your plugin works fine. But site database pages are using old software and cannot use later than D3 V4.

Viewing 3 replies - 16 through 18 (of 18 total)
  • The topic ‘Very interesting plugin’ is closed to new replies.