Support » Plugin: Enhanced Publication » Version update (has_cap was called with deprecated argument)

  • If you receive the following error (notice) in WordPress:
    “Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Applications/MAMP/htdocs/dirbkjrk/wp-includes/functions.php on line 2923”

    Change the epub.php file ( wp-content->plugins->enhanced-publication):

    Go to function epub_menu
    New:
    function epub_menu()
    {
    add_options_page(‘Enhanced Publication’, ‘Enhanced Publication’, ‘manage_options’, ‘enhanced-publication/epub_settings.php’);
    }

    Old:
    function epub_menu()
    {
    add_options_page(‘Enhanced Publication’, ‘Enhanced Publication’, 8, ‘enhanced-publication/epub_settings.php’);
    }

    https://wordpress.org/plugins/enhanced-publication/

  • The topic ‘Version update (has_cap was called with deprecated argument)’ is closed to new replies.