WordPress.org

Support

Support » How-To and Troubleshooting » Version Control for Themes

Version Control for Themes

  • Hi all. Already I’m futzing with themes. Naturally I’d like to keep things under a VCS (Subversion, in this case). I can’t think of a useful solution.

    It appears that there’s no way to test themes w/o installing WP on your local machine, so (assuming I don’t do that) I have to change, ftp, test..etc.

    Also since my ISP probably won’t allow me to install Subversion, I’d be stuck with making builds on my local machine, ftp-ing them over, testing them, and then merging the changes locally.

    Yuck.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Yes, that’s the reason why I have a local copy of my site as well, to test changes/new plugins/new themes/hacks/upgrades/etc.

    Some editors support saving to FTP, which safes some hassle, but you still won’t have version control on them.

    But do you run them on your own machine locally?

    I thought of installing a local copy of WordPress (I’m doing it right now), so that I could at least use my own machine for testing and as the repository. Then if all is well I can ftp it up to the ISP. I’ll also be able to see if the Subversion housekeeping futzes WP!

    I looked into the remote Subversion options, and it mostly depends on things I can’t get from the ISP right now: WebDAV, terminal support, and new/recent software installations.

    I run the live version remotely and have a local copy running as well for the things I mentioned above.

    Okay that makes sense to me. I installed WP on my machine, but the admin/install script can’t connect. Weird, since every other MySQL script & app I have works fine! I suspect I’m missing something…

    Asking the obvious:
    – The settings in wp-config.php are correct?
    – That user exists withing MySQL?
    – That user has access to the WordPress database?
    – With what tool did you create the user?

    All of the above is fine. It’s my normal root account for MySQL – works from Perl & from little apps. I used both the shell & a little exploration widget app that uses the hostname, username, and password. I can connect from either, just fine. Weird. I have a .cnf file; maybe that’s affecting it.

    Does it work from other PHP apps?

    Also, find this line in the wp-includes/wp-db.php file and remove the @ from it. This should give you a more descriptive error message. (Don’t forget to put it back afterwards)
    $this->dbh = @mysql_connect($dbhost, $dbuser, $dbpassword);

    I even tried this:
    <http://wordpress.org/support/topic/60343?replies=10&gt;

    Okay I need to debug…argh I don’t know php!

    What’s the error message you get after removing the @?

    Huh. It gives me ‘access denied’.

    Hah! It’s my root password. It’s changed somehow, and I don’t know when. A secondary user password worked. What could have changed my root password? Can the .cnf file do that…? Oh well.

    Can you log into MySQL from the console using that root password?

    If so, I think you’re being bitten by this.
    Before trying the workaround in that post please create a new user for wordpress, because I don’t know what the effects will be for existing applications that already use the existing account.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Version Control for Themes’ is closed to new replies.