Support » Plugin: CSS & JavaScript Toolbox » version 9.4 installation stuck – table wp_cjtoolbox_templates missing

  • Resolved Yggy

    (@yggydrasil)


    Version 9.4 installation stuck at step “Add WordPress built-in scripts and styles as CJT Templates so it can be used via Templates Lookup form.”

    Error log (anonymised) shows wp_cjtoolbox_templates isn’t found and after checking database wp_cjtoolbox_templates isn’t there.

    [Mon Feb 17 10:39:46.742809 2020] [php7:notice] [pid 15643] [client clientip:62376] WordPress databasefout Table 'wpsite.wp_cjtoolbox_templates' doesn't exist bij query SELECT * FROM wp_cjtoolbox_templates WHERE 1!=1 LIMIT 0,1; gemaakt door do_action('wp_ajax_cjtoolbox_api'), WP_Hook->do_action, WP_Hook->apply_filters, CJTAjaxAccessPoint->route, do_action('wp_ajax_cjtoolbox_install'), WP_Hook->do_action, WP_Hook->apply_filters, CJTAjaxController->_doAction, CJTInstallerController->installAction, CJTInstallerModel->install, CJTInstaller->wordpressTemplates, CJTInstallerWordpressQueueTemplates->install, CJTxTable::getInstance, CJTTemplateTable->__construct, CJTxTable->__construct, CJTMYSQLQueueDriver->getColumns, CJTMYSQLQueueDriver->select, referer: https://wpsite/wp-admin/admin.php?page=cjtoolbox
    [Mon Feb 17 10:39:46.742865 2020] [php7:warn] [pid 15643] [client clientip:62376] PHP Warning:  mysqli_num_fields() expects parameter 1 to be mysqli_result, boolean given in /var/www/html/wpsite/html/wp-includes/wp-db.php on line 3353, referer: https://wpsite/wp-admin/admin.php?page=cjtoolbox
    [Mon Feb 17 10:39:46.742877 2020] [php7:warn] [pid 15643] [client clientip:62376] PHP Warning:  Invalid argument supplied for foreach() in /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/framework/db/mysql/queue-driver.inc.php on line 184, referer: https://wpsite/wp-admin/admin.php?page=cjtoolbox
    [Mon Feb 17 10:39:46.742995 2020] [php7:error] [pid 15643] [client clientip:62376] PHP Fatal error:  Uncaught Exception: Field:name is not found! in /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/framework/db/mysql/xtable.inc.php:352\nStack trace:\n#0 /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/framework/db/mysql/xtable.inc.php(379): CJTxTable->prepareQueryParameters(Array)\n#1 /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/includes/installer/installer/includes/templates/wordpress-queue.inc.php(84): CJTxTable->save()\n#2 /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/includes/installer/installer/installer.class.php(112): CJTInstallerWordpressQueueTemplates->install()\n#3 /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/models/installer.php(163): CJTInstaller->wordpressTemplates()\n#4 /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/controllers/installer.php(53): CJTInstallerModel->install()\n#5 /var/www/html/wpsite/html/wp-content/plugins/css-j in /var/www/html/wpsite/html/wp-content/plugins/css-javascript-toolbox/framework/db/mysql/xtable.inc.php on line 352, referer: https://wpsite/wp-admin/admin.php?page=cjtoolbox

    .htaccess is normal
    php memory is 512MB
    php version is 7.2.24

Viewing 6 replies - 1 through 6 (of 6 total)
  • Yggy

    (@yggydrasil)

    Tried to create the table wp_cjtoolbox_templates manually in the database by using the code from /css-javascript-toolbox/includes/installer/installer/db/mysql/structure.sql

    This results in following error

    MySQL said: Documentation
    #1709 - Index column size too large. The maximum column size is 767 bytes.

    Trying to find the cause + solution, but currently not succesful.

    I use MariaDB 10.1.44

    Plugin Author wipeoutmedia

    (@wipeoutmedia)

    Hi Yggy,

    Thank you for reaching out.
    Although installation issues are rare, there a few reasons why the installation fails and may be caused by the PHP memory being to low, or a security (or .htaccess) plugin set too high. What you have listed seems perfectly fine, so it may be that MariaDB config info needs to be modified, such as turning on large prefix. There are a few other things you can try to get it past the Add WordPress built-in scripts installation stage.

    There is a good step by step guide here that may help: https://stackoverflow.com/questions/35847015/mysql-change-innodb-large-prefix

    Please let me know how you get on.
    [ Signature deleted ]

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @wipeoutmedia Thanks for the great support but please lose the signature. That’s prohibited in these forums as it’s been horribly abused in the past by others.

    Thanks

    Kind Regards,
    Damian Baker

    Yes, bad people ruin it for others. No, I am not kidding. Please refrain from that.

    https://wordpress.org/support/guidelines/#avoid-signatures

    Plugin Author wipeoutmedia

    (@wipeoutmedia)

    HI Jan,

    Sure, no problems.
    It is just habit, but I will refrain from using signatures.
    Thanks for sharing the WordPress guidelines. I’ll make time to read that.

    Yggy

    (@yggydrasil)

    Reason for installing this plugin became obsolete due to programming a custom solution instead. For future projects it might still be interesting to have this plugin working, so was able to test the suggested guide today.

    The following lines were already in place of the MariaDB config:

    
    innodb_large_prefix     = on
    innodb_file_format      = barracuda
    innodb_file_per_table   = true
    

    Added the following line to the config:

    
    innodb_default_row_format = DYNAMIC
    

    After rebooting of the MariaDB service and doing a clean install of the plugin in the site, the additional install seems successful.

    No time yet to fully test the plugin, but it is probably safe to say this topic is resolved. Thanks!

    Plugin Author wipeoutmedia

    (@wipeoutmedia)

    Thank you for following up with the config code and posting the results.
    I am glad everything worked out for you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘version 9.4 installation stuck – table wp_cjtoolbox_templates missing’ is closed to new replies.