Support » Plugin: YARPP - Yet Another Related Posts Plugin » version 5.10.0 generated error 500

  • Resolved fredericobt

    (@fredericobt)


    Hello. I needed to disable the plugin because it was causing a 500 error (Internal Server Error) throughout the site after upgrading to version 5.10.0.

    I am at your disposal to perform tests and help to discover the root cause of the problem.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author yarpp

    (@jeffparker)

    Hi @fredericobt thank you so much for the report and the offer to help.

    – Is there any more detail on the 500 error in your error logs?
    – What is your PHP version?
    – Which other plugins do you have installed?

    Same issue here immediately after updating to 5.10.0 on a multisites installation.

    Site #1 on the network: posts displaying other related posts caused 500 errors
    Site #2 on the network: posts displaying other related posts worked OK

    Back to normal after deactivating YARPP.

    Plugin Author yarpp

    (@jeffparker)

    @one2net Can you please share what is in your server error logs? Any additional detail that can help us replicate the issue would be very helpful.

    If you do not want to share publicly, please email: jay at yarpp.com

    I had this problem as well, caused huge issues for two of my blogs today, and hard to debug as it only showed up on posts but not pages; fortunately, I could see that YARPP had been auto-upgraded last night so I could disable it to test.

    Behaviour: post loading times out with 500 error.

    Example of errors logged (doesn’t matter the PHP memory limit, basically it fills it all up):

    AH01071: Got error 'PHP message: PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 24576 bytes) in (...)/wp-includes/formatting.php on line 584PHP message: PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried
     to allocate 65536 bytes) in (...)/wp-includes/functions.php on line 3461PHP message: PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 53248
     bytes) in Unknown on line 0'

    Disabling the plugin immediately resolved the issue.

    • This reply was modified 1 year, 1 month ago by mgc8.
    Plugin Author yarpp

    (@jeffparker)

    @mgc8 @one2net @fredericobt can you please shoot me an email? jay at yarpp.com

    I’d like to give you a development version to test to see if it resolves the issue. We’d really appreciate it.

    Thread Starter fredericobt

    (@fredericobt)

    I am having the same PHP error as @mgc8.

    I also experieced the 500 error after upgraded to this new version. Here are a couple example items in my error log:

    [23-Oct-2020 15:15:35 UTC] WordPress database error Unknown column 'yarpp.ID' in 'order clause' for query SELECT SQL_CALC_FOUND_ROWS ls_posts.*, CASE ls_posts.ID WHEN 15634 THEN 57.9713 WHEN 24425 THEN 53.0659 WHEN 20033 THEN 42.7365 WHEN 24398 THEN 42.0407 WHEN 20125 THEN 39.1818 WHEN 24419 THEN 35.0876 END as score FROM ls_posts WHERE 1=1 AND ls_posts.ID in (15634,24425,20033,24398,20125,24419) AND ls_posts.post_type = 'my-product' ORDER BY score DESC, yarpp.ID ASC limit 6 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ls-child/base.php'), include('/themes/ls-child/single-my-product.php'), get_template_part, locate_template, load_template, require('/themes/ronneby/templates/portfolio/inside-folio_inside_1.php'), get_template_part, locate_template, load_template, require('/themes/ls-child/templates/portfolio/folio-description.php'), yarpp_related, YARPP->display_related, WP_Query->query, WP_Query->get_posts

    [23-Oct-2020 14:23:42 UTC] PHP Fatal error: Allowed memory size of 805306368 bytes exhausted (tried to allocate 40960 bytes) in .../wp-includes/wp-db.php on line 1999

    • This reply was modified 1 year, 1 month ago by Daniel Chase.

    Exact same… updated the plugin, and all the “post pages” (where I use YARPP) broke… Essentially a timeout…

    Had to disable plugin.

    Plugin Author Michael Nelson

    (@mnelson4)

    Thanks for the info everyone. It sounds like YARPP is interfering with some other plugin or theme.
    @riseofweb thanks for the stack trace. Do you know what plugin or theme is adding the custom post type “my-product”? That might be the other plugin or theme that YARPP is interfering with.

    If everyone else can provide us with their active plugins and current theme, we’ll hopefully be able to identify the problem.

    Plugin Author yarpp

    (@jeffparker)

    Please accept our sincere apologies for the trouble that the update caused.

    We had a lot packed into the update. As a patch, we have released v5.10.1 that reverts the troublesome code while we figure out what the conflict is. Can you please install it and let us know if it works for you? @fredericobt has already confirmed privately.

    https://wordpress.org/plugins/yet-another-related-posts-plugin/#developers

    Hello,

    Thank you for the quick action on this.

    I can confirm that updating the plugin to version 5.10.1 solved the issue on both of my blogs.

    Here is a list of the common installed plugins:

    
     wp-security-scan
     add-meta-tags
     akismet (inactive)
     async-javascript
     better-plugin-compatibility-control
     better-search-replace
     broken-link-checker
     elegant-themes-updater
     exclude-pages
     fancybox-for-wordpress
     google-sitemap-generator
     hello-dolly (inactive)
     hikari-category-permalink
     iwp-client
     nextgen-gallery
     nospamnx
     page-links-to
     varnish-http-purge
     relevanssi
     scrapebreaker
     simple-share-buttons-adder
     simply-show-ids
     wp-piwik
     wp-maintenance-mode
     yet-another-related-posts-plugin
    

    The templates are variations from older Elegant Themes (not Divi).

    Regards,
    Mihnea

    Plugin Author Michael Nelson

    (@mnelson4)

    Thanks @mgc8, I’ll start trying to test with those.
    FYI we found one bug in our code that may have been the culprit, but we haven’t yet seen the “Memory Exhaustion” error and so aren’t certain if we’ve fixed that.
    If any of you are able to test our fixed version (a version which also has the database query optimization, and hopefully avoids the 500 error), it would be very helpful.
    Here’s how:
    1. Download the new version from here: https://drive.google.com/file/d/10HDyTe7I5d_BaZXlPWPP95tNAXV6OljI/view?usp=sharing
    2. Go to your WordPress dashboard, click plugins, then “add new”, then “upload” and select the zip file you just downloaded
    3. Deactivate the previous version of YARPP
    4. Activate the new version of YARPP

    If you get the same error as before, please let us know

    this special version does not solve the problem for me … unfortunately

    just registered, sent you active plugin list and errors through mail before

    • This reply was modified 1 year, 1 month ago by hofstaetter.
    • This reply was modified 1 year, 1 month ago by hofstaetter.
    Plugin Author Michael Nelson

    (@mnelson4)

    Thanks @hofstaetter, so it must only address the other, smaller issue. Thanks, it probably won’t fix it for anyone else either then. We’ll see if we can reproduce the problem with the other plugins you’re using then work on another fix.

    Thread Starter fredericobt

    (@fredericobt)

    My plugin list:
    Antispam Bee
    Autoptimize
    Cloudflare Page Cache
    Custom 404
    Disable XML-RPC Pingback
    Display Posts
    Edge Cache HTML via Cloudflare Workers
    Fluent Forms
    Flying Analytics by WP Speed Matters
    Importador do WordPress
    Loco Translate
    LuckyWP Table of Contents
    Rank Math SEO
    Reading Time WP
    Redirection
    Regenerate Thumbnails Advanced
    Search & Filter
    ShortPixel Image Optimizer
    Social Feed Gallery
    Social Snap Lite
    UpdraftPlus – Backup/RestoreWhite Label
    Wordfence Security
    WP Mail SMTP
    WPS Hide Login
    Yet Another Related Posts Plugin (YARPP)

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘version 5.10.0 generated error 500’ is closed to new replies.