Support » Plugins and Hacks » [Resolved] Version 4.4.0 with gn_ compatibility mode

[Resolved] Version 4.4.0 with gn_ compatibility mode

  • I have just upgraded to the latest version.

    All of my shortcodes are the old ‘gn_’ variety.

    In my functions file I have:

    # Fix Shortcodes Ultimate Compatibility Mode
    update_option('su_compatibility_mode_prefix', 'gn_');

    All shortcodes were working prior to the upgrade but none are working now.. all my sidebar widgets now show:

    [gn_posts template="templates/teaser-loop.php" posts_per_page="6" tax_term="featured" orderby="parent"]

    Actually I just solved my own problem by re-saving the option in Shortcodes > Settings > Compatibility mode, so maybe I’ll leave this post here to help others who might stumble across the same problem.

    And to express my LOVE for this plugin.. LOVE IT and can’t live without it, it’s the best wordpress plugin ever invented and you are a legend.


Viewing 15 replies - 1 through 15 (of 20 total)
  • Solved by clicking “Save Changes” in Shortcodes > Settings > Compatibility mode

    I love you! I was ranking my brain trying to see what was wrong with shortcodes and I found your answer. Your suggestion worked like a charm. I unchecked the “compatibility mode” option and all my shortcodes started working again (none where working before.) Thank you again!

    Thanks man! Saved the day 🙂

    I actually had to uncheck it in order for it to work for me…

    I just looked at mine and it was already enabled. Do I need to do anything?

    Hi Scott,

    Only if things are broken for you..

    Scenario #1
    if, before the upgrade,you were using compatibility mode (shortcodes starting with su_), then you need to leave compatibility mode enabled for your shortcodes to work

    Scenario #2
    if, before the upgrade, you weren’t using compatibility mode (shortcodes didn’t start with su_ but used straight shortcodes like [tab] [button] etc, then you need to disable compatibility mode for your shortcodes to work

    Scenario #3
    If, before the upgrade, you were using the ‘old’ shortcodes from the original plugin (shortcodes start with gn_ instead of su_), then you need to add this to your theme’s functions.php and leave compatibility mode enabled

    # Fix Shortcodes Ultimate Compatibility Mode
    update_option('su_compatibility_mode_prefix', 'gn_');

    Scenario #4
    If you are new to this plugin and don’t have any shortcodes yet, but you use a lot of different plugins or premium themes, then I would personally leave compatibility mode enabled because that means you can switch to different themes and use different plugins down the track, without any disturbance to your sites. (It’s a real pain to have conflicting shortcodes, where one plugin or theme both use the same shortcode, i.e. [columns] etc. The website breaks because 2 different things are calling the same shortcode, so having compatibility mode enabled is the safest setting for new users).

    For one of my site’s I’m using these codes and had to turn compatibility mode off after the upgrade to 4.4.4
    [column size=”1-2″]
    [column size=”1-2″ last=”1″]

    On another site I’m using these and compatibility mode is also off.
    [tabs style=”2″]
    [tab title=””]

    On another site I’m using these and compatibility mode is also off.
    [tabs style=”1″]
    [tab title=””]

    I just noticed that another update was released to this plugin, its up to 4.4.6
    So you’re saying that as long as compatibility mode is off I shouldn’t have any problems as long as I’m using the old codes like I mentioned here and not the new su ones?


    Thanks! Solved my problem. I’m new to this plugin.

    Sorry Scott, I don’t get email notifications and only visit this forum when there is an update in the plugin.

    Yep, your shortcodes are the normal kind… so you just need to make sure that compatibility mode is not enabled and you should be good to go..

    (Shortcodes > Settings > Uncheck Compatibility mode)

    Latest version: 4.5.0

    People using the old gn_ shortcode no longer need to add extra details to functions.php

    We now just go to:

    Shortcodes > Settings
    Add gn_
    to Shortcodes prefix

    OK, let me get this straight. I was using the gn_ shortcode.

    1) After I update the plugin, shortcodes WILL BE messed up, but after I apply
    Shortcodes > Settings
    Add gn_
    to Shortcodes prefix

    then they will go back to normal, right?

    2) Has there been any word from the author on what should we expect in the future – will the shortcodes be changed again? Will the compatibility mode work? This is a fix for now, but who knows will it work in the future.


    1.) yep, that’s all I did.. added
    to shortcodes > settings
    and everything went back to normal

    2.) I have no idea what the author things but I think this is the long term permanent fix.. it’s definitely the best version so far (instead of messing with and remembering to add stuff to functions, etc)

    Just thought I would add to this thread as I have been tearing my hair out.

    Firstly good advice with the settings, however my short codes don’t have su_ or gu_ in them the ones i have on my site are [tabs style=”1″][tab title=”Title 1 example”] and then [/tab] at the end of a paragraph.

    In the Shortcodes prefix field of the settings I simply deleted the su_ and left it blank. Saved changes and it was sorted.

    Some other codes don’t work so I changed them to the new ones and it is sorted now.

    Great plugin, thank you so much for creating it, but please don’t do updates like this again. Surely you change the code associated with the shortcode not the shortcode itself!

    I am on version 4.5.3 now. I finally managed to get it to work.

    Sort of. Several problems remain. More about that in a minute. But, to get existing codes to work, I went to Settings and REMOVED the preface. All the old codes work now. Well mostly.

    Here’s my current problem:

    I can insert this link into a browser window and it will work – http://www.nyghtfalcon.com/NewSite/gallery/biographies/jd-milazzo/

    When I use this link from within our new test bed site, (http://www.nyghtfalcon.com/test-bed/) I get the NyghtFalcon home page.

    I can’t find a “button link” short code in this version and many of the parameters no longer apply. Is there a simple list of short codes and all the permutations?

    Please disregard. I deactivated the plugin then reactivated it. Everything is working.

    Just wanted to point out that like @jimf81 I simply deleted the su_ prefix and that took care of the problem for me. However, I did have custom css I added in the initial install that was wiped out. Luckily I made all my changes on a beta site and had it all backed up.

    Make sure you have your customizations backed up before making any of these changes.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Version 4.4.0 with gn_ compatibility mode’ is closed to new replies.