Support » Fixing WordPress » Version 4.4 update – Fatal error: Class 'WP_Widget' not found

  • Resolved GiacomoJames

    (@giacomojames)


    Hallo

    I have worked my way through various problems today in updating to 4.4. I repeated earlier (successful) steps to manually update, but this time got the message in the dashboard and on the site:

    Fatal error: Class ‘WP_Widget’ not found in /websites/123reg/LinuxPackage22/al/ly/so/allysonpollock.com/public_html/wp-content/plugins/akismet/class.akismet-widget.php on line 5

    I can’t now access the dashboard or site
    allysonpollock.com

    Any advice would be much appreciated!

    Best wishes

    James

Viewing 15 replies - 1 through 15 (of 33 total)
  • Moderator Matthew

    (@kidsguide)

    Volunteer Moderator

    This is an error with the Akismet plugin from the looks of it. You will need to go into your FTP and navigate to wp-content > plugins. You should see a folder names akismet. Rename that folder to whatever you want as long as it is different.

    Hopefully that should enable you to access your admin again.

    Dear Matthew

    Thanks very much for getting back to me so quickly. I’ve tried your suggestion, but no luck.

    A new error message says:

    Fatal error: Class ‘WP_Widget’ not found in /websites/123reg/LinuxPackage22/al/ly/so/allysonpollock.com/public_html/wp-content/plugins/mailchimp/mailchimp_widget.php on line 481

    Would you suggest following the same procedure for MailChimp and any other plugins?

    Best wishes

    James

    Moderator Matthew

    (@kidsguide)

    Volunteer Moderator

    Yes, I would just disable all your plugins. You can do so by just renaming the plugins folder to plugins.hold.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    It is not an error with your plugins. Your upgrade was incomplete for some reason.

    Download a fresh copy of the WordPress ZIP file and do a manual upgrade.

    I’ve got this same error message. And I had thought that I’d be in agreement with you Samuel Wood (Otto) on downloading the ZIP and overwriting. But in doing so, I’m still having the problem. Hrm. I will try once more to upload a complete 4.4 of WordPress to see if it works after the second try.

    I may be on to something. I’ve got the same error occurring on multiple sites on the same server, but not on other servers. More investigating required apparently.

    I’m having the same issue:

    PHP Fatal error:  Class 'WP_Widget' not found in /var/www/stage/mexico-resort.stage.duable.com/html/wp/wp-includes/widgets/class-wp-widget-pages.php on line 17
    Fatal error: Class 'WP_Widget' not found in /var/www/stage/mexico-resort.stage.duable.com/html/wp/wp-includes/widgets/class-wp-widget-pages.php on line 17

    This is showing as missing within the WP core so its definitely not a plugin issue. I made sure by deleting all plugins including akismet.

    I’m running a LEMP server with PHP 5.5.9-1ubuntu4.14 – any help would be appreciated!

    SOLVED

    I was using WP Cli and it needed to be upgraded. Check out this handy post for solutions to common 4.4 issues:

    https://wordpress.org/support/topic/read-this-first-wordpress-44-master-list?replies=5

    P.S. This post should probably be added to the WP dashboard if wp_debug is turned on – it would have saved me and others time. Just a thought.

    Thanks mohammad. I hadn’t even considered it was just WP Cli, as Infinite WP was also having trouble updating the accounts, I just assumed it was across the board. Oops. But yes. I updated WP Cli and I’m not getting the error anymore.

    Thanks very much indeed for this discussion.

    Regarding Mohammad and techdruid’s comments on WP-CLI – I’ve had a look at this – http://wp-cli.org/ and other sites – but have to say I haven’t understood what it is and how to update it, or apparently related matters like cURL or wget.

    Might someone be able to point me to where to start?

    Many thanks

    Giancomo –

    WP-CLI is meant for developers who build and run their own web servers – not the typical practice for WordPress website owners. If you are not using SSH (or are not familiar with SSH) then WP-CLI is not the issue for your website.

    What host are you using for your WordPress website that is causing issues?

    Thanks mohammad. The host is 123-reg. My guess had been that the problem was the plugins so I hadn’t contacted them.

    Hi all

    I got same error than Giacomo but I’m a very basic user. Not even know what SSH is. Do you guys recommend to contact with my host for this error?

    Giacomo + ssvandin –

    You should first try manually reinstalling the updated version of WordPress:
    https://codex.wordpress.org/Updating_WordPress

    Secondly, you should try disabling all plugins.

    Thirdly, you should try setting your theme to the default theme that came bundled with WordPress (TwentyFifteen or TwentySixteen).

    If all the steps above still lead to the same errors then you should contact your host and verify there are no major errors in the log.

    I have one site with this same error – it does NOT use WP CLI

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Version 4.4 update – Fatal error: Class 'WP_Widget' not found’ is closed to new replies.