Support » Plugin: Cloudflare » Version 4.5.0 Crashes website!

  • Gaillimh

    (@gaillimh)


    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.7.2
    Current plugin: Cloudflare (version 4.5.0)
    PHP version 8.0.5

    Error Details
    =============
    An error of type E_ERROR was caused in line 15 of the file /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php. Error message: Uncaught Error: Failed opening required ‘/var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap80.php’ (include_path=’.:/usr/share/php’) in /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php:15
    Stack trace:
    #0 /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(69): require()
    #1 /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(59): composerRequire386a6fce91e17b37d63cb251597d5bd5()
    #2 /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/vendor/autoload.php(7): ComposerAutoloaderInit386a6fce91e17b37d63cb251597d5bd5::getLoader()
    #3 /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/cloudflare.loader.php(3): require_once(‘…’)
    #4 /var/www/[redacted]/public_html/wp-content/plugins/cloudflare/cloudflare.php(49): require_once(‘…’)
    #5 /var/www/[redacted]/public_html/wp-settings.php(391): include_once(‘…’)
    #6 /var/www/[redacted]/public_html/wp-config.php(126): require_once(‘…’)
    #7 /var/www/[redacted]/public_html/wp-load.php(37): require_once(‘…’)
    #8 /var/www/[redacted]/public_html/wp-admin/admin-ajax.php(22): require_once(‘…’)
    #9 {main}
    thrown

Viewing 15 replies - 1 through 15 (of 15 total)
  • Thread Starter Gaillimh

    (@gaillimh)

    How can I roll back to 4.4.0?

    zarifis

    (@zarifis)

    Version 4.5.0 Crashes websites

    I had to access two of my sites using the recovery access so I could deactivate the Cloudflare 4.5.0 plugin because it made two of my 11 WordPress 5.7.2 sites to crash

    Site information:
    WordPress version 5.7.2
    Current theme: Twenty Nineteen (version 2.0)
    Current plugin: Cloudflare (version 4.5.0)
    PHP version 8.0.3

    Id and site names changed to X and Y

    Error Details
    =============
    An error of type E_ERROR was caused in line 15 of the file /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php. Error message: Uncaught Error: Failed opening required '/home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap80.php' (include_path='.:/opt/alt/php80/usr/share/pear:/opt/alt/php80/usr/share/php:/usr/share/pear:/usr/share/php') in /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php:15
    Stack trace:
    #0 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(69): require()
    #1 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(59): composerRequire386a6fce91e17b37d63cb251597d5bd5()
    #2 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/vendor/autoload.php(7): ComposerAutoloaderInit386a6fce91e17b37d63cb251597d5bd5::getLoader()
    #3 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/cloudflare.loader.php(3): require_once('/home/XXXXXXXXX...')
    #4 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-content/plugins/cloudflare/cloudflare.php(49): require_once('/home/XXXXXXXXX...')
    #5 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-settings.php(391): include_once('/home/XXXXXXXXX...')
    #6 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-config.php(106): require_once('/home/XXXXXXXXX...')
    #7 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-load.php(37): require_once('/home/XXXXXXXXX...')
    #8 /home/XXXXXXXXX/public_html/YYYYYYYYYYYYY.com/wp-login.php(12): require('/home/XXXXXXXXX...')
    #9 {main}
      thrown

    @gaillimh, you can go to https://ru.wordpress.org/plugins/cloudflare/advanced/, scroll to the bottom of the page and you will see an option to download previous versions of the plugin.

    I manually rollback to 4.4.0 version until a bug a fixed.

    tom coady

    (@tomcoady)

    Maybe CF should downgrade this update until the bug is fixed?

    whouk

    (@whouk)

    I’ve had this issue across all of my WordPress sites too. I had to rollback to 4.4.0 to resolve the problem and get the sites working again.

    Neo

    (@firefliespilots)

    Hello, same problem after the update. I will switch to Stackpath. More reliable than Cloudflare. A service like Cloudflare should do a better job of maintaining your plugin. We pay Cloudflare Pro and get delivered crap that destroys the whole website? Horror club!

    reforced

    (@reforced)

    PHP 8.0 is not officially supported; but it’s an easy fix. The error mentions the following file missing:
    /wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap80.php

    You can download that file from Symfony repo yourself below:
    https://github.com/symfony/polyfill-intl-normalizer/blob/main/bootstrap80.php

    Neo

    (@firefliespilots)

    Hello @reforced

    Did I miss a train? I pay Cloudflare so that I should do the lack of development work myself? Then it’s time to make the whole PHP 8 compliant.

    Thread Starter Gaillimh

    (@gaillimh)

    @malferov Thanks!

    @reforced Ah, that explains it.

    Is it just me or has Cloudflare really dropped the ball on this plugin? They rarely reply on this forum and it seems pretty shocking that they would roll out this update with a critical error on PHP 8. Some of us are paying a lot of money for the Pro or Business plan. Surely they could invest some money on some basic support here?

    Neo

    (@firefliespilots)

    @gaillimh 👍‍‍👍‍‍

    zarifis

    (@zarifis)

    I submitted a ticket to Cloudflare – I’ll let you know what they come back with…

    zarifis

    (@zarifis)

    Workaround is posted at https://community.cloudflare.com/t/update-cf-plugin-wordpress/274280/3

    Cloudflare plugin 4.5.1 has been released. I updated my 12 sites to this version with no issues – did not remove the bootstrap89.php file that was specified in the workaround above.

    Neo

    (@firefliespilots)

    @zarifis with php8?

    zarifis

    (@zarifis)

    @firefliespilots – yes, PHP 8. Glad you asked, I forgot to mention.

    I used the bootstrap80.php workaround posted on github to fix the 4.5.0 issue initially. I installed 4.5.1 with no problems – but I also did NOT undo the workaround.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Version 4.5.0 Crashes website!’ is closed to new replies.