Support » Plugin: Geolocation IP Detection » Version 4.0 Public Beta – AJAX shortcodes

  • Plugin Author Benjamin Pick

    (@benjamin4)


    Version 4.0 Public Beta – AJAX shortcodes

    As supporting the shortcodes in AJAX mode required some bigger code changes, I am releasing a beta first – could you please try it out and tell me if you find PHP errors/notices or bugs?

    https://github.com/yellowtree/geoip-detect/archive/4.0.zip

    https://github.com/yellowtree/geoip-detect/wiki/Beta-Testing

    Release Log:

    = 4.0.0 =
    * NEW: Shortcodes can now also be resolved in AJAX mode (without coding JS).

    If you are using a page cache, AJAX mode is the best solution for you. And thanks to shortcodes, this doesn’t need custom coding anymore.
    You can keep using the same shortcodes as before – just tick the options “Enable AJAX endpoint” and “Resolve shortcodes (via AJAX)”.
    Instead of doing the geo-lookup while generating the HTML, it will generate boilerplate HTML (for the cache) that will be filled by the plugin’s JS automatically (in the client’s browser).

    The following shortcodes are currently not implemented: [geoip_detect2_show_if] and [geoip_detect2_hide_if]

    * Minimum PHP version is now 7.2

    * Using PHP Type-Hinting for API functions – if you used the PHP API, please test it (I didn’t change parameter types of the function arguments but just in case)

    * Minimum WordPress version is now 5.0

    * If you are using WooCommerce, you need at least version 3.9.0 (released Jan 2020) – otherwise this plugin lookup disables itself

    * Updated vendor code

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.