Support » Fixing WordPress » Version 3.5 No longer allows 'Visual' editing

  • Resolved capnsully


    similar to this thread and others, my WP install for now doesn’t permit visual editing of posts. This makes posting of longer, more complex updates a real pain.

    I have tried disabling all plugins and also reverting to the 2011 standard theme, both with no luck.

    I am on Inmotion hosting, not sure if that helps.



Viewing 8 replies - 1 through 8 (of 8 total)
  • You’ll need to go through all the troubleshooting steps in this thread – what you’ve done is just a start — and right now it looks like you have many plugins and your regular theme still active.

    Hi, as I mentioned, I’d previously tried disabling all plugins and also reverting to the Twenty Eleven theme. I’ll leave the site like that for 15 hrs or so, but because of our subscription plugins, I don’t like leaving it deactivated for much longer.

    I have taken a full backup of the site and DB. But I am very fearful of deleting ANY files as I have no idea if by doing this I’ll break the site! here is a screenie of the files in the public_html directory.


    I’ve read the instructions here , but am still worried that I’ll delete something essential. After deletion, will I need to reinstall 3.5? Even though this has already been done automatically on (I think!) 28 Dec. 2012?

    i’ve tried clearing the browser’s cache and cookies, no fix.

    I can’t recall where the ‘Dr’ diagnostic program is, do you know where that is and would it be useful if I run?

    As we are not full time HTML or web experts, this is rapidly becoming a pain, I hope we can fix ‘easily’. I’m surprised this issue can crop up so easily.



    I’m not experiencing this problem though I searched Google for this:

    visual editor not working wordpress 3.5

    …and found this…

    Based on information from past forums of people struggling with this on old versions of WordPress, I installed the “Use Google Libraries” plugin, and then activated it (don’t forget to activate it, as it won’t activate automatically after installation).

    It worked! Apparently the plug-in “Allows your site to use common javascript libraries from Google’s AJAX Libraries CDN, rather than from WordPress’s own copies.” I’m not so sure about all that, but it fixed my issue with the Visual editor! (Giving me the feeling that my site is held together with my own sloppy coding/template adaptations, duct tape, shoe string and now plugins!)


    This solution has worked for several users.

    Failing the above, try the following:

    I had this same issue and fixed it by doing the following:

    Go to Users->”Username” and check the box that says “Disable the visual editor when writing”. Update Profile.
    Go to Post or Page and verify that the visual editor is disabled.
    Go back to Users and uncheck the box and save.

    After doing that when I went back to the Page/Post I was trying to edit everything was fixed.


    Brilliant! The Use Google Libraries plugin magically fixed the visual editor issue. The user profile fix didn’t work, but I don’t care, since the first did.

    Thanks so much, and yes, I did google quite a bit myself, but got bogged down with all this initial gobbledegook about complex manual installs….

    Thanks again


    Glad to help. Don’t forget to mark as solved.



    Tried that but didn’t change anything.



    @pcemml: It’s best to post your response to the thread that you originally created if you want further support from other members.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Version 3.5 No longer allows 'Visual' editing’ is closed to new replies.